0

I'm trying to start an RPC node but the command below has only works once

monero-wallet-rpc --rpc-bind-port 18081 --wallet-file monero-pool --prompt-for-password --daemon-address 127.0.0.1:18089 --untrusted-daemon --disable-rpc-login --rpc-bind-ip 127.0.0.1 --confirm-external-bind

I start the daemon with the following command:

./monerod --public-node --p2p-bind-ip=0.0.0.0 --p2p-bind-port=18080 --rpc-bind-ip=0.0.0.0 --rpc-bind-port=18081 --rpc-restricted-bind-ip=0.0.0.0 --rpc-restricted-bind-port=18089 --confirm-external-bind --detach

Once I enter the RPC command I need to enter my password and everything looks fine except after a couple of seconds I get:

2023-09-18 08:45:11.286 F Error starting server: Failed to bind IPv4 (set to required)
2023-09-18 08:45:11.286 E Failed to initialize wallet RPC server

I tried rebooting the VPS and the command killall monerod. I can confirm that there is no monerod running after the killall command. But the RPC node won't start up

It feels like I'm missing something stupid but I'm not sure what.

I can confirm my daemon is running because I can connect my monero-wallet-gui with the remote node and ./monerod status is returning the following:

Height: 2976766/2976766 (100.0%) on mainnet, not mining, net hash 2.19 GH/s, v16, 12(out)+27(in) connections, uptime 0d 0h 15m 56s

ps -e | grep monero gives me: 1131 ? 00:00:38 monerod so the rpc node is not running as a stale process

1
  • it doesn't mather if I trie monero-wallet-rpc or ./monero-wallet-rpc, same error
    – J_P
    Sep 18, 2023 at 9:02

1 Answer 1

0

You can't use --rpc-bind-port=18081 on both daemon and wallet RPC. Use different ports.

You can't ask two completely separate processes to listen on the same port.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.