1

I'm having an issue with using the Monero RPC.

My node is all setup and working and using monero-wallet-cli I can create a wallet, send funds etc, however when I try to use the RPC I get the following error.

I'm new to playing around with Monero node's RPC calls etc but I'm trying to learn and I'm sure its something really silly.

root@localhost:/walllet# monero-wallet-rpc --rpc-bind-port 18081 --rpc-login deleted:deleted --wallet-file wallet --prompt-for-password
This is the RPC monero wallet. It needs to connect to a monero
daemon to work correctly.

Monero 'Oxygen Orion' (v0.17.3.0-release)
Logging to monero-wallet-rpc.log
2022-03-27 10:46:04.818 W Loading wallet...
Wallet password: 
2022-03-27 10:46:11.683 W Loaded wallet keys file, with public address: (DELETED)
2022-03-27 10:46:12.000 W Transaction extra has unsupported format: <cb3856dee480e70255a403bb12d0e53c392abd89e8fbaacc70bb919f58e822ad>
2022-03-27 10:46:12.000 W Transaction extra has unsupported format: <792bddbc428562d20354e40d5d6e5ec95897b0a166449ab0ebb19a21371c3b2a>
2022-03-27 10:46:12.001 W Transaction extra has unsupported format: <bb064c4b76631b8e74ff0c5f5fae55fd2cad116cf5d9341b865dddda150b340c>
2022-03-27 10:46:12.001 W Transaction extra has unsupported format: <da198baca3a5e7268d9da22fb10bbf1b0c807ed9e3ac80cd1621b9e367910149>
2022-03-27 10:46:12.116 W Background mining not enabled. Run "set setup-background-mining 1" in monero-wallet-cli to change.

This is the part I'm struggling with. I don't get why I cant bind to port 18081 on 127.0.0.1 as nothing else is bound to it (as far as I'm aware).

2022-03-27 10:46:12.116 I Binding on 127.0.0.1 (IPv4):18081
2022-03-27 10:46:13.483 F Error starting server: Failed to bind IPv4 (set to required)
2022-03-27 10:46:13.483 E Failed to initialize wallet RPC server

Any help or pointing in the right direction would be very grateful.

1 Answer 1

1

This is the part I'm struggling with. I don't get why I cant bind to port 18081 on 127.0.0.1 as nothing else is bound to it (as far as I'm aware).

The daemon binds on port 18081 (by default) for the daemon RPC interface, and you are trying to start the wallet RPC binding on the same port. That's why you get the error starting monero-wallet-rpc with --rpc-bind-port 18081. Simply use another unused port instead here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.