0

I configured the monero RPC with the following command lines:

1/ Firstly I run the monero daemon : ./monerod --testnet --rpc-bind-ip=x.x.x.x --rpc-bind-port=28081 --rpc- login user:password --confirm-external-bind

2/Then I configured the monero RPC : ./monero-wallet-rpc --wallet-file testwallet --password test --rpc-bind- port 28082 --rpc-bind-ip=x.x.x.x --daemon-address x.x.x.x.x:28081 - -testnet --daemon-login user:password --log-level 4 --confirm-external-bind

and the connection is done successfully but when I used it with the CURL it posted a message: "Unauthorized Access".

Can you help me?

1

Either disable RPC authentication (--disable-rpc-login) or give user:password to curl in digest mode.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.