0

I've been having trouble connecting to my monero remote note from outside my local network.

This is the command I've been using to launch the daemon:

monerod.exe --data-dir E:/bitmonero --rpc-bind-ip 0.0.0.0 --restricted-rpc --confirm-external-bind

I can connect to the node inside my local network using my internal IP (I have no problem with 192.x.x.x addresses) but cannot connect outside my local network with either my internal or external public IP.

--rpc-bind-ip <my external IP> also does not work and I can only get it to work with my internal IP or 0.0.0.0 as shown above.

I've also opened up ports 18080, 18081 on the device I'm running the node on as well as on went into my router and forwarded these ports to the internal IP of the device running the node.

However, I seem to be getting quite a lot of incoming connections - currently at 8(out) +35(in).

Any help would be appreciated!

  • anyone able to help? – Electric_Sheep01 Jul 9 '18 at 6:37
  • Do you use a firewall? If so, please try disabling it completely to see if it could be the cause – Endogen Jul 10 '18 at 7:16
  • Firewall is not the problem – Electric_Sheep01 Jul 12 '18 at 3:26
2

--rpc-bind-ip [IP ADDRESS] Binds the daemon to an IP address. You need to use your External IP if you plan to access this daemon from outside your local network, or an Internal IP if you only want it to work for devices in the same local network.

--rpc-bind-ip 0.0.0.0 In the context of a local network, 0.0.0.0 means 'all the IP addresses inside the local network'. So the daemon bonded to internal IPs can be reachable only by internal addresses and not from outside the local network.

You should use --rpc-bind-ip [YOUR EXTERNAL IP ADDRESS] to make the daemon reachable from outside your LAN. Additionally, you must set firewall rules and forward ports depending on your particular local network and router configuration.

0

It seems you are running your node on your private LAN on a machine which only has a 192.168.X.X IP.
So it seems normal you could not bind to your public IP address.

However, are you trying to connect to your public IP address from outside your network, since you said you forwarded the ports to your node private IP?
Do you have a default route via your router private IP on your node?

  • Well I'm getting inbound connections (99+ currently) so it seems to not be just on my LAN network. Yes I am trying to connect to my public IP address outside of my network, when entering the external IP of the device in port forwarding within my router settings It does not let me. – Electric_Sheep01 Jul 12 '18 at 3:24
  • In port forwarding you should enter your node 192.168 address for the port 18081. This way, when you connect to your public ip on port 18081 it will redirect the connection to your node on the same port. – el00ruobuob Jul 12 '18 at 5:05

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.