3

I provide user and password in config file, but I got the error as it tries to create .login file. When I run for the first time it runs without restriction, but when I run for the second time, it throws error.

docker-compose up Starting monerodocker_monero_1 ... Starting monerodocker_monero_1 ... done Attaching to monerodocker_monero_1 monero_1 | 2018-04-10 11:18:35.660 7fafb52e0740 INFO global src/daemon/main.cpp:279 Monero 'Helium Hydra' (v0.11.1.0-release) monero_1 | Forking to background... monero_1 | Monero 'Helium Hydra' (v0.11.1.0-release) monero_1 | Logging to ./monero-wallet-rpc.log monero_1 | 2018-04-10 11:18:35.674
7f4811fef740 ERROR wallet.rpc src/wallet/wallet_rpc_server.cpp:198 Failed to create file monero-wallet-rpc.18557.login. Check permissions or remove file monero_1 | 2018-04-10 11:18:35.674
7f4811fef740 ERROR wallet.rpc src/wallet/wallet_rpc_server.cpp:1894 Failed to initialize wallet rpc server monerodocker_monero_1 exited with code 1

2

I had the exact same error message when running monero-wallet-rpc without the option --disable-rpc-login.

Then, as explained by vtnerd in this open issue:

The file is always created in the current working directory when authentication is enabled.

To create the file, you need to be the owner of the working directory.

I set the current user within the docker container as the owner of the working directory, so Check permissions disappeared and monero-wallet-rpc started correctly.


By the way:

When leaving --disable-rpc-login you should provide --rpc-login user:password.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.