3

I have a Monero daemon running on a Raspberry Pi connected to my LAN and it worked fine for sometimes, but lately, I'm unable to connect wallet from another PC to it.

When the issue has happened for the first time, I followed the suggestion to recreate the blockchain (maybe it was corrupted) and everything worked again. The problems happened yet and copying again a new healthy blockchain didn't solve the issue this time.

I use this command on server:

./monerod --rpc-bind-ip=192.168.xx.xx --rpc-bind-port=4008 --confirm-external-bind

And this one on client:

./monero-wallet-cli --daemon-address 192.168.xx.xx:4008 --wallet-file mywallet

The daemon works fine and syncs all the blockchain. If I use status command, I get:

Height: 1487860/1487860 (100%) on mainnet, not mining, net hash 669.86 MH/s, v6, up to date, 8(out)+0(in) connections, uptime 0d 1h 19m 48s

The wallet starts with this message ´Error: refresh failed: no connection to daemon. Please make sure daemon is running.. Blocks received: 0´ and ever shows this prompt:

[wallet 4xxxxx (no daemon)]:

What can I do to solve this issue?

  • Is there a firewall, and is it allowing those connections ? – user36303 Jan 15 '18 at 17:20
  • 1
    Try using --daemon-host instead of --daemon-address with monero-wallet-cli. – scoobybejesus Jan 15 '18 at 17:20
  • @user36303 firewall is active but only for connection outside LAN. – cialu Jan 16 '18 at 8:30
  • @scoobybejesus if I use --daemon-host with --daemon-port, I get the same result as --daemon-address. – cialu Jan 16 '18 at 8:35
  • Can you reach the server with telnet ? If not, then it's a network problem, not a monero problem. – user36303 Jan 16 '18 at 11:04
1

I have removed the folder lmdb from .bitmonero directory, then I started again the daemon and synced the blockchain. All works fine now and the wallet (monero-wallet-cli) can easily connect to the daemon through the LAN.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.