1

I had my new Version: 0.11.0.0 Helium Hydra linux 64 bit gui up and running, transferred my coins to it, shut it down and now the demon won't start up.

I get this - "Error: Couldn't connect to daemon: 127.0.0.1:18081\n" daemon not running. checking again in 2 seconds.

I suspect that the \n on the end of the demon address is the problem but I have no idea how to fix it.

Can somebody point me in the direction of a way to either get this wallet working or an alternative way to get my coins out and into something reliable?

Linux mint 18.2 Linux otb3 4.10.0-33-generic #37~16.04.1-Ubuntu SMP Fri Aug 11 14:07:24 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Thanks in advance for your help! G

  • Go to the settings page in the GUI, select the entire port widget text (triple click should do it), and leave it blank. – user36303 Sep 19 '17 at 15:04
  • Hi @user36303, thank you for your help, I cleared the port setting in the gui > settings and tried to start the daemon, it is still not connecting. I still get ¨Error: Couldn´t connect to daemon 127.0.0.1:18081\n¨ Any other ideas? – Gilfoyle1 Sep 19 '17 at 15:50
  • Try adding 18081 in that widget ? And make sure to press delete at the end in case that gets rid of \n characters. – user36303 Sep 19 '17 at 16:34
  • yeah i´ve tried that already, I have opened a bug over on git hub, the developer is looking at it i think. – Gilfoyle1 Sep 19 '17 at 17:08
1

@G

I'm not sure if you sorted your problem, but have you tried running the daemon from a CLI with the command ./monerodYou can use ./monerod -h to see a list of options that can be used.

If that fires it up okay, at least you'll know that the issue is not with the daemon, but maybe with the GUI.

The '\n' looks to me like it could be a bug in the GUI which is displaying the LF as '\n'

-2

Try running this with:

sudo ./

in front of the command and see what happens. I had an install once where my username would error out and it would run fine if I ran it as root. I can't remember what I did. I may have imported the wallet as root or something like that.

  • 1
    This is awful advice. Running random stuff as root not only papers over the problem in case it really is a permissions-being-screwed-up issue, but actually makes things worse by making permissions screwed up for anything written. Besides, it allows any compromise of that software to have direct kernel access instead of having to use a kernel exploit next. – user36303 Oct 12 '17 at 7:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.