3

I’m messing with monero-universal-pool and I have the blockchain synced, the wallet RPC going (at log level=2 and just showing green DEBUGSs and blue info/blocks received INFO, and I can connect miners to the pool. When I have the RPC going and go to my admin page I get this error:

Error

Wallet:

  • Last check: less than a minute ago
  • Last status: fail
  • Last response: {}
  • Last fail: less than a minute ago
  • Last fail response: {}

The daemon checks out with a green "OK".

If I turn off the kill the RPC, I get the error:

Wallet:

  • Last check: less than a minute ago
  • Last status: fail
  • Last response:

     {"code":"ECONNREFUSED","errno":"ECONNREFUSED","syscall":"connect"}
    
  • Last fail: less than a minute ago
  • Last fail response:

     {"code":"ECONNREFUSED","errno":"ECONNREFUSED","syscall":
    

So, if with the RPC on it gives me a Fail and no explanation just { }. Does anyone know where I might look to try to fix this to where it says “ok”? I get it that without the RPC being active that it is going to give me the above “code” error, but I don’t get why it would fail and not throw an error when connected.

I tried made sure my config.json is in order:

{
    "coin": "Monero",
    "symbol": "XMR",
    "coinUnits": 100000000,
    "coinDifficultyTarget": 120,

    "logging": {
        "files": {
            "level": "info",
            "directory": "logs",
            "flushInterval": 5
        },
        "console": {
            "level": "info",
            "colors": true
        }
    },

    "poolServer": {
        "enabled": true,
        "clusterForks": "auto",
        "poolAddress": "44XjW8cg418JmtooiVgKzUCnQFbMEzkFtD1mW2fqDCQSgv5hok4QfZzQuRCKWydkrYik8Vj3VaLc22zLDFRW7EtDJyGS6jR",
"addressBase58Prefix": 18,
        "blockRefreshInterval": 1000,
        "minerTimeout": 900,
        "ports": [
            {
                "port": 3333,
                "difficulty": 100,
                "desc": "Low end hardware"
            },
            {
                "port": 5555,
                "difficulty": 2000,
                "desc": "Mid range hardware"
            },
            {
                "port": 7777,
                "difficulty": 10000,
                "desc": "High end hardware"
            },
            {
                "port": 8888,
                "difficulty": 10000,
                "desc": "Hidden port",
                "hidden": true
            }
        ],
        "varDiff": {
            "minDiff": 2,
            "maxDiff": 100000,
            "targetTime": 100,
            "retargetTime": 30,
            "variancePercent": 30,
            "maxJump": 100
        },
        "fixedDiff": {
            "enabled": true,
            "addressSeparator": "."
        },
        "shareTrust": {
            "enabled": true,
            "min": 10,
            "stepDown": 3,
            "threshold": 10,
            "penalty": 30
        },
        "banning": {
            "enabled": true,
            "time": 600,
            "invalidPercent": 25,
            "checkThreshold": 30
        }
    },

    "payments": {
        "enabled": true,
        "interval": 600,
        "maxAddresses": 50,
        "mixin": 3,
        "transferFee": 5000,
        "minPayment": 3000000,
        "denomination": 1000
    },

    "blockUnlocker": {
        "enabled": true,
        "interval": 30,
        "depth": 60,
        "poolFee": 0.45,
        "devDonation": 0.001,
        "coreDevDonation": 0.001,
        "extraFeaturesDevDonation": 0
    },

    "api": {
        "enabled": true,
        "hashrateWindow": 600,
        "updateInterval": 5,
        "port": 8117,
        "blocks": 30,
        "payments": 30,
        "password": "xxxxxxxxx"
    },

    "daemon": {
        "host": "127.0.0.1",
        "port": 18081
    },

    "wallet": {
        "host": "127.0.0.1",
        "port": 8082
    },

    "redis": {
        "host": "127.0.0.1",
        "port": 6379
    },

    "monitoring": {
        "daemon": {
            "checkInterval": 60,
            "rpcMethod": "getblockcount"
        },
        "wallet": {
            "checkInterval": 60,
            "rpcMethod": "getbalance"
        }
    },

    "charts": {
        "pool": {
            "hashrate": {
                "enabled": true,
                "updateInterval": 60,
                "stepInterval": 1800,
                "maximumPeriod": 86400
            },
            "workers": {
                "enabled": true,
                "updateInterval": 60,
                "stepInterval": 1800,
                "maximumPeriod": 86400
            },
            "difficulty": {
                "enabled": true,
                "updateInterval": 1800,
                "stepInterval": 10800,
                "maximumPeriod": 604800
            },
            "price": {
                "enabled": true,
                "updateInterval": 1800,
                "stepInterval": 10800,
                "maximumPeriod": 604800
            },
            "profit": {
                "enabled": true,
                "updateInterval": 1800,
                "stepInterval": 10800,
                "maximumPeriod": 604800
            }
        },
        "user": {
            "hashrate": {
                "enabled": true,
                "updateInterval": 180,
                "stepInterval": 1800,
                "maximumPeriod": 86400
            },
            "payments": {
                "enabled": true
            }
        }
    }
}

Everything else seems like it is working (the daemon and the pool) but according to the admin panel the Wallet isn’t working even though it looks like the RPC is running ok. I don’t get it and without at least an error displayed I can’t research it further. A few Google searches including { } didn't yield much. Help!

  • I still have not found out what is causing this. I tried binding a different port in the command line and making sure it was also set in config.json wallet area and forwarding that port all to no avail. Can anyone point me to help? With the lack of information for the error it is making researching it near impossible. What would the error { } mean? I have looked at many related posts. I can duplicate their errors and resolve them (ERRCONNECT..etc) using 127,0,0,1 in the wallet area and bind that ip and port 8082 to the wallet but I get the { } error and the fail still. – Dom Sobieralski Feb 12 '18 at 5:10
  • I tried to deleting the monero-wallet-cli.8082.login since after I moved my server into the basement the rpc was giving me an error and stopping about not being able to write to the login file. I deleted the login file and reran the rpc and it is not throwing any errors but I still have the { } 'fail' and I suspect when the pool finds a block the miners won't be paid. Does anyone have any ideas? I may try binding to another open port and see if I get the same error or not. Other than that (and I don't think that will make a difference) I am out of ideas. Anyone want to chime in? – Dom Sobieralski Feb 16 '18 at 2:26
  • Update: I went through the monero-wallet-rpc.log file and I keep on coming across this error: http protocol handler .inl:547 HTTP_RESPONSE_HEAD << HTTP/1.1 401 Unauthorized Server Epee-based. So, because it is a 401 ( log in with user ID and password) how do I find out what address it is calling to and correct the missing log in information? I didn't see anything like that in the config.json. At least I may be on the right track. – Dom Sobieralski Feb 17 '18 at 5:19
  • I tried to mess with the binding settings on the command line to start the RPC. Nothing seems to have changed. The RPC runs and continues to give INFO, WARN and TRACE but I can see that periodically (I am guessing when it is trying to access the server?) that in the logs it gives the 401 error and then continues to do its thing. A couple of lines from the monero-wallet-rpc.log 2018-02-14 10:58:02.981 [RPC0] TRACE net.http contrib/epee/include/net/http_protocol_handler.inl:547 HTTP_RESPONSE_HEAD: << HTTP/1.1 401 Unauthorized Server: Epee-based Content-Length: 98 Content-Type: text/html – Dom Sobieralski Feb 17 '18 at 18:23
1

I had this problem and it turned out my blockchain was corrupt. I had to resync monerod to fix it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.