1

I'm hoping someone with a little more experience can help me with this pool I am setting up on a VPS for the CryptoNote DigitalNote (XDN). I have the server up and running, node, wallet, daemon, redis all configured but I am running into an error when miners try to connect. The VPS node init.js displays this error when a miner tries to connect:

http://i.imgur.com/5vh9yQK.jpg Error: Failed to parse block at Object.BlockTemplate.nextBlob etc

I tried using LucasJones' version of cryptonote-utils as recommended here (cryptonote-universal-pool Stratum authentication failed) but that just introduces another error with address verification so it isn't fixing anything just covering up the block error. I've been told that this may have to do with XDN adding merged mining and that it changed the block format.

Does anyone have any advice for getting this setup? It's so close. Thank you.

2

At least part of the solution might be in the answer below - address checking assumes Monero, and between various CryptoNote cryptocurrencies there are some differences in how addresses are made - see here for some explanation and you can try some XDN address in the tool to see how it is built - the difference is mainly in the network byte so any code dealing with addresses would need to be looked at and patched accordingly.

The second error is most likely due to an address being passed which doesn't match the expected format. This can be due to two reasons: either the address is really wrong (Monero addresses are 95 characters long, and start with a 4), or the pool's address being wrongly set (the pool will compare the first character of the miner address with the pool address' first character and expect the same).

The address validation code is at the end of lib/utils.js (isValidAddress). You can add traces to see which part of it fails.

With regards to merged mining support, I'm not aware of some ready-to-use solution and I don't know how to solve your problem (and I doubt many here have experience with XDN in particular, but maybe someone pops in with a better answer), it might be worthwhile to look into this pool released by the XDN team: https://github.com/xdn-project/cryptonote-universal-pool

Analyzing the difference between that one and the original might give some hints. Maybe that pool works out of the box - did you try that one as well?

  • Thank you for your comment. I am going to bypass the address authentication function for debugging purposes until I can get the miners to connect successfully. I checked out the address verification code and thought I did it correctly (both types: checking mining address vs pool address format and also using the correct base58 prefix of 0xDB for digitalnote). I still received address errors (not sure what I am doing wrong), so I will forget the address authentication aspect for now. I tried many different forks etc similar to the XDN team project to no avail. – ron Jun 6 '17 at 22:52
  • I actually decided to stick with XDN project version once I realized what is going on, but it suffers from the same error out of the box unfortunately. I have contacted dNote (devs), but I would like to fix this sooner hmmm PS thank you for the address test link. – ron Jun 6 '17 at 22:52
  • 1
    Okay, so I have confirmed that the reason the pool software does not work is because of a change in XDN block format. There were 2 forks since the pool code has been updated. One in Nov 2016 that added Merged Mining support and another in Jan 2017 that updated block size and added RingCT for XMR merge mining. I have been working on converting the pool code over and devs will help out if I do not finish in a month or so. – ron Jun 9 '17 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.