3

Title says, my server is stuck between 100-300 blocks behind. It has been oscillating for days like this. Here is a custom log output of how many blocks behind I am:

time:14:36:11 block:150
time:14:37:03 block:147
time:14:38:52 block:147
time:14:39:16 block:148
time:14:40:05 block:149
time:14:41:00 block:147
time:14:43:33 block:147
time:14:48:13 block:147
time:14:48:26 block:147
time:14:51:01 block:142
time:14:51:32 block:147
time:14:51:41 block:150
time:14:52:20 block:150
time:14:53:46 block:151
time:14:54:19 block:152
time:14:54:59 block:153
time:14:57:04 block:151
time:14:57:49 block:151
time:14:58:57 block:151
time:14:58:58 block:151
time:15:02:44 block:155
time:15:04:31 block:155
time:15:06:56 block:154
time:15:07:32 block:154
time:15:08:02 block:154
time:15:10:23 block:156
time:15:10:30 block:156
time:15:13:03 block:158
time:15:14:02 block:159
time:15:14:15 block:159
time:15:14:58 block:160
time:15:15:38 block:157
time:15:18:44 block:155
time:15:18:50 block:155
time:15:19:45 block:156
time:15:19:51 block:156
time:15:20:36 block:155
time:15:22:59 block:157
time:15:23:09 block:157
time:15:23:37 block:157
time:15:25:03 block:158
time:15:25:37 block:156
time:15:26:10 block:156
time:15:27:14 block:156
time:15:28:53 block:157
time:15:29:39 block:157
time:15:31:50 block:155
time:15:31:53 block:155
time:15:33:25 block:157

Things I tried to fix this are add --block-sync-size 10 to the service startup, and I also deleted the last 1000 blocks and resynced them using, monero-blockchain-import --pop-blocks 1000.

Any suggestions on what else to do?

update

I notice this error is common:

2017-12-28 15:57:30.056 [P2P0]  ERROR   verify  src/cryptonote_core/blockchain.cpp:3042 Timestamp of block with id: <42ef1903bfb1677b7d2cf7eac866654a9b0e8cf0fc29bea9b9cf5165ee42cb12>, 1514484069, bigger than adjusted time + 2 hours
2017-12-28 15:57:30.056 [P2P0]  ERROR   verify  src/cryptonote_core/blockchain.cpp:3153 Block with id: <42ef1903bfb1677b7d2cf7eac866654a9b0e8cf0fc29bea9b9cf5165ee42cb12>
has invalid timestamp: 1514484069

paraphrased: Timestamp of block bigger than adjusted time + 2 hours: block has invalid timestamp.

  • 1
    Your server has the correct time, right? – scoobybejesus Dec 28 '17 at 23:49
  • haha thats a great thing to look into, I just reinstalled the OS. – Tsangares Dec 29 '17 at 2:14
  • That worked, my server synced within a minute. – Tsangares Dec 29 '17 at 2:31
4

scoobybejesus recommended I make sure the server time was correct. I am on Arch Linux, so I ran timedatectl set-ntp true to sync my clock and the Monero server synced within a minute.

Looks like I forgot to run that when I installed the OS a few days ago.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.