3

I have a 15 inch mid 2010 Macbook pro, running macOS Sierra 10.12. I still get bus error 10, similar to what I got with the previous release. I have also updated my OS recently - it didn't change a thing.

What happens when I run Monero daemon is this (identifying information omitted with XXXXXXXXX):

Last login: Wed Dec 28 10:40:54 on ttys000

/Users/XXXXXXXXX/Downloads/monero.mac.x64.v0-10-1-0/monerod ; exit

XXXXXXXXXXXX

/Users/XXXXXXXXX/Downloads/monero.mac.x64.v0-10-1-0/monerod ; exit;

Creating the logger system

2016-Dec-28 10:42:47.538600 Initializing cryptonote protocol...

2016-Dec-28 10:42:47.538749 Cryptonote protocol initialized OK

2016-Dec-28 10:42:47.539035 Initializing p2p server...

2016-Dec-28 10:42:47.835838 Set limit-up to 2048 kB/s

2016-Dec-28 10:42:47.835962 Set limit-down to 8192 kB/s

2016-Dec-28 10:42:47.836020 Set limit-up to 2048 kB/s

2016-Dec-28 10:42:47.836162 Set limit-down to 8192 kB/s

2016-Dec-28 10:42:47.840377 Binding on 0.0.0.0:18080

2016-Dec-28 10:42:47.840644 Net service bound to 0.0.0.0:18080

2016-Dec-28 10:42:47.840695 Attempting to add IGD port mapping.

2016-Dec-28 10:42:51.859277 No IGD was found.

2016-Dec-28 10:42:51.859394 P2p server initialized OK

2016-Dec-28 10:42:51.859586 Initializing core rpc server...

2016-Dec-28 10:42:51.859804 Binding on 127.0.0.1:18081

2016-Dec-28 10:42:51.860059 Core rpc server initialized OK on port: 18081

2016-Dec-28 10:42:51.860192 Initializing core...

2016-Dec-28 10:42:51.862051 Loading blockchain from folder 
/Users/XXXXXXXXX/.bitmonero/lmdb ...

2016-Dec-28 10:42:51.862130 option: fast

2016-Dec-28 10:42:51.862163 option: async

2016-Dec-28 10:42:51.862190 option: 1000

Bus error: 10

logout

Saving session...

...copying shared history...

...saving history...truncating history files...

...completed.
1

BUS error most likely happens when you have a corrupt database, which causes the LMDB code to try to access an invalid memory page, causing the SIGBUS.

Unfortunately, it means you have to delete your data.mdb and resync from the network.

If you're seeing this, it might be prudent to set a "safer" database acccess mode. See Why does my bitmonero fail to load?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.