Ever since the fork, I have been unable to get monerod to work for more than a day, if that. I have reloaded the database several times, but they all crash the same way.

My latest effort got the following:

2017-09-20 21:27:53.077     7fe5aa00f780    INFO    global  src/daemon/main.cpp:279 Monero 'Helium Hydra' (v0.11.0.0-release)
2017-09-20 21:27:53.078     7fe5aa00f780    INFO    global  src/daemon/protocol.h:55    Initializing cryptonote protocol...
2017-09-20 21:27:53.078     7fe5aa00f780    INFO    global  src/daemon/protocol.h:60    Cryptonote protocol initialized OK
2017-09-20 21:27:53.078     7fe5aa00f780    INFO    global  src/daemon/p2p.h:63 Initializing p2p server...
[1505942873] libunbound[2658:0] info: warning: unsupported algorithm for trust anchor . DS IN
[1505942873] libunbound[2658:0] warning: trust anchor . has no supported algorithms, the anchor is ignored (check if you need to upgrade unbound and openssl)
sendto: Network is unreachable
2017-09-20 21:28:05.383     7fe5aa00f780    INFO    global  src/daemon/p2p.h:68 P2p server initialized OK
2017-09-20 21:28:05.383     7fe5aa00f780    INFO    global  src/daemon/rpc.h:58 Initializing core rpc server...
2017-09-20 21:28:05.383     7fe5aa00f780    INFO    global  contrib/epee/include/net/http_server_impl_base.h:70 Binding on
2017-09-20 21:28:05.383     7fe5aa00f780    INFO    global  src/daemon/rpc.h:63 Core rpc server initialized OK on port: 18081
2017-09-20 21:28:05.383     7fe5aa00f780    INFO    global  src/daemon/core.h:73    Initializing core...
2017-09-20 21:28:05.384     7fe5aa00f780    INFO    global  src/cryptonote_core/cryptonote_core.cpp:323 Loading blockchain from folder /home/jacques/.bitmonero/lmdb ...
Bus error (core dumped)

I am running Ubuntu 14.04 on two different computers and downloaded monerod via the GUI wallet to each one, but, since I see the problem is the daemon, I am running it from the command line. The problem exists on both machines.

Please, any help you can offer will be appreciated.

  • Can you try downloading the standalone cli daemon and try running that? Sep 21, 2017 at 12:50
  • 1
    Try running with the --max-concurrency 1 flag first. Thus, ./monerod --max-concurrency 1. If that doesn't work, please apply #2492.
    – dEBRUYNE
    Sep 21, 2017 at 14:25
  • Ran with your suggestion, got "Segmentation fault". Not sure what I should do re #2492. Are you suggesting I don't have the most updated copy of monerod?
    – user592440
    Sep 24, 2017 at 10:12

1 Answer 1


Bus error is a typical symptom of a corrupt blockchain, though 0.11 is meant to switch to LMDB safe mode to avoid such corruption once the blockchain is synced - something which appears not to have helped here.

One possible way out is to run monerod with --db-salvage, which will make monerod attempt to use the previous state of the blockchain database. This is a one off flag: the next time you run monerod, do not run with --db-salvage again (unless also corrupt).

If this doesn't work, a full blockchain resync is probably necessary.

If you feel like doing this, you can also run gdb on the core file to see where the bus error comes from. It's very likely to come from the LMDB code, but maybe it doesn't:

gdb monerod core*

Replace monerod with the path to monerod if it's not in the current directory. Also, if you have several core files, use the correct (it should be the most recent one). If you do not have a core file, you may need to run these first:

ulimit -c unlimited
echo core | sudo tee /proc/sys/kernel/core_pattern

The message you quoted says "core dumped", but some recent distros seem to lie about it.

  • Deleted the db and then ran monerod again in the terminal. As expected, it began to rebuild the db from scratch. I watched it for about an hour, it seemed very happy. Then I shut down the terminal and starte monerod again. This time I got the same errors as in my previous posts, so it seems that monerod is corrupting the db when it is shut down, in Ubuntu 14.04. So I ran the first two lines you suggest and got "No stack". Quit gdb, ran the second two lines, and then the first two. Still got "No stack".
    – user592440
    Sep 24, 2017 at 10:05
  • If you're not using the current master, use it. It's got a crash fix which might be what you're seeing (but hard to tell since no stack). There is no need to delete the chain again after switching to master.
    – user36303
    Sep 24, 2017 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.