0

I accidentally deleted my monero wallet.

I was having trouble restoring the wallet via the GUI 12.3 using the mnemonic seed. My seed is recognised when I attempt to restore the wallet. I previously used the seed to restore my wallet successfully post the change to version 12 of the GUI.

I know approximately the time I created the wallet and have set the block height restore point 1 day prior. I have also tried setting the restore point to the start of the blockchain without success. I even tried creating the wallet on a different PC.

I have checked the settings of the GUI and the current block matches https://xmrchain.net/.

I don't really know what to do next. I am not sure where I have gone wrong. Am i correct in thinking that the mnemonic seed corresponds to a private key and would not change? Or is it possible I am using an old seed and I should have written down a new seed post the upgrade to version 12 or I could have changed this accidentally while using the wallet?

I would be very appreciative of any help that anyone could provide.

  • A given 25 word Monero mnemonic seed will always correspond to a certain Monero private spend key, as the mnemonic seed is simply a representation (in words) of the private spend key. Thus, your seed won't change if you upgrade to a new (major) version. Are you certain that (i) your daemon is fully synced and (ii) your blockchain is not corrupt? – dEBRUYNE Aug 29 '18 at 14:31
  • Thanks for your reply. As you can probably discern from the newbish nature of my questions I wouldn't go as far as to say I am certain. I have tried re-installing the GUI a couple of times and it indicates that it is fully synced. How can I assess if the blockchain is corrupt? One odd aspect is that my seed is accepted as valid - then when the GUI is synced I go to view private keys/seed and a different seed is shown. – scroogemcd Aug 30 '18 at 23:24
  • You can basically assess whether your blockchain is corrupt by syncing with a remote node. First, switch to a remote node (see -> getmonero.org/resources/user-guides/remote_node_gui.html). Thereafter, go to the Settings page and change the Wallet creation height (under Debug info) to 1400000. This will trigger a wallet refresh, which may take an hour or so. Now, there are some circumstances where the seed changes. Put differently, two different seeds correspond to the same public address. I won't go into details here, because that would get quite technical. [1/2] – dEBRUYNE Aug 31 '18 at 9:01
  • Lastly, have you verified that the public address is the same as your old / initial wallet? [2/2] – dEBRUYNE Aug 31 '18 at 9:03
  • Are you sure you're using the correct seed, and not one for a empty test wallet ? While it does sound "duh", it happened before :) – user36303 Sep 22 at 14:18
0

The Mnemonic seed is imutable. It does not change upon a version upgrade.
If your seed is recognized by the GUI or CLI, then it is valid.
Did you checked your balance before deleting your wallet file? Was it accurate?
You should see the incomming and outgoing transaction in your history after the wallet is synced. Check if nothing's missing here.

  • Hey thanks for the reply. My balance was accurate prior to deletion. None of my transaction history is showing. – scroogemcd Aug 28 '18 at 14:07
  • Could you try restoring from wallet-cli and see if it sees any transactions? – el00ruobuob Aug 28 '18 at 14:24
  • Is your address correct? Maybe you generated two wallets back in times and restored the wrong one. – el00ruobuob Aug 28 '18 at 14:24
  • Are you using a local node, or a remote node? – el00ruobuob Aug 28 '18 at 15:17
  • Using a local node. Good suggestion on the cli wallet will try restoring via that method tonight. I am very confident that I previously restored the wallet via the seed I am using. I guess if I am unable to restore it might be that I somehow restored using a private key as opposed to the seed previously. Really appreciate your help. – scroogemcd Aug 28 '18 at 23:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.