0

I'm really getting so frustrated - cannot resolve following issue:

  • My wallet is showing the wrong balance

  • I cannot transfer any money ("Daemon is busy")

Seems like I am on the wrong chain, right?

So I tried following this guideline:

I forgot to upgrade (from CLI or GUI v0.11 to CLI or GUI v0.12) and, as a result, accidentally synced to the wrong (alternative) chain

I updated from 12.2 to 12.3 and now I've been waiting for days and theres nothing happening. I am on Macosx High Sierra using the GUI version.

This is what my log says:

[31.07.18 09:01] Height: 1622140/1622140 (100.0%) on mainnet, not mining, net hash 458.90 MH/s, v7, up to date, 0(out)+0(in) connections, uptime 0d 8h 1m 44s [31.07.18 09:02] Height: 1622140/1622140 (100.0%) on mainnet, not mining, net hash 458.90 MH/s, v7, up to date, 0(out)+0(in) connections, uptime 0d 8h 2m 44s

The latest transaction to this wallet happened in block no "1615882" with now "No of confirmations: 12630" - these funds are not showing in my wallet and I cannot transfer the existing funds...

I do not want to delete the whole blockchain and start over from scratch...

Do you have any tips? I really do need the money :( - Thank u

  • Do you vaguely remember when you first made a transaction to this particular wallet? Btw, your Show status output looks OK (i.e. you are on the correct chain). – dEBRUYNE Jul 31 '18 at 10:45
  • thank you for your reply! ah okay, so I am on the right chain - then that's even more confusing. The first transaction was in block height 1581264, I reduced my wallet creation height to claim my funds. – j doe Jul 31 '18 at 18:01
  • So a second transaction is missing? What is the output of this guide (for the transaction that is missing)? monero.stackexchange.com/questions/6137/… – dEBRUYNE Jul 31 '18 at 18:42
  • Okay no, the first transactions are all fine and showing up. There seems to be a problem only with the last one (Block height 1615882 as mentioned above). The test gives me "This address owns output 0 with pubkey XXX for amount XXX" Next line "This address doesn't own output with pubkey XXX for amount XXX" and total received: XXX, indicating the correct amount of XMR - so from here everything looks fine – j doe Aug 1 '18 at 7:58
  • Okay now not using GUI: I popped the blocks as described below, resynced for ages - now I have my funds in the wallet-cli! GUI version still not showing right funds although "fully synced" --- that thing is a mess! – j doe Aug 1 '18 at 8:32
0

You should try to rescan your wallet for spent output with rescan_spent from the cli. It should remove your spent transaction done on the wrong blockchain.

Otherwise you could try to pop the blocks to restart syncing before the transaction:
./monero-blockchain-import --pop-blocks 6500
This will remove the 6500 blocks and when you will restart monerod it will sync again.

Edit: try first option. If it does not help, pop the blocks and scan again.

  • Thank you for your answer! Option 1 did not have any effect (no wonder, since it seems that I am indeed on the right chain).. so I'm trying option two now... – j doe Jul 31 '18 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.