1

Certainly not looking to sync the daemon fully as it's just too much data for my purposes:

2023-05-22 01:07:54.389 I Synced 70252/2688967 (2%, 2618715 left)
2023-05-22 01:07:55.060 I Synced 70352/2688967 (2%, 2618615 left)
2023-05-22 01:07:55.183 I p2p net loop stopped
2023-05-22 01:07:55.551 I Stopping core RPC server...
2023-05-22 01:07:55.551 I Node stopped.
2023-05-22 01:07:55.551 I Deinitializing core RPC server...
2023-05-22 01:07:55.552 I Deinitializing p2p...
2023-05-22 01:07:55.564 I Deinitializing core...
2023-05-22 01:07:59.221 I Stopping cryptonote protocol...
2023-05-22 01:07:59.222 I Cryptonote protocol stopped successfully
nicholas@mordor:~$ 
nicholas@mordor:~$ monerod print_status
2023-05-22 01:08:13.201 I Monero 'Oxygen Orion' (v0.17.2.0-unknown)
Error: monerod is NOT running
nicholas@mordor:~$ 
nicholas@mordor:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 22.04 LTS
Release:    22.04
Codename:   jammy
nicholas@mordor:~$ 

So, am using a remote node as:

[wallet 42mEMY (no daemon)]: 
[wallet 42mEMY (no daemon)]: refresh
Error: wallet failed to connect to daemon: node.xmr.to:18081. Daemon either is not started or wrong port was passed. Please make sure daemon is running or change the daemon address using the 'set_daemon' command.
[wallet 42mEMY (no daemon)]: 
[wallet 42mEMY (no daemon)]: status
Refreshed 2688832/?, no daemon connected
[wallet 42mEMY (no daemon)]: 

and while it's about 80% sync'ed it's just not completing. I've tried a few remote nodes without any further progress.

What are my options to fully sync the wallet?

after rebooting, and trying a different remote node:

**********************************************************************
Use the "help" command to see a simplified list of available commands.
Use "help all" to see the list of all available commands.
Use "help <command>" to see a command's documentation.
**********************************************************************
Warning: using an untrusted daemon at node.moneroworld.com:18089
Using a third party daemon can be detrimental to your security and privacy
You are strongly encouraged to connect to the Monero network using your own daemon
If you or someone you trust are operating this daemon, you can use --trusted-daemon
Background mining not enabled. Run "set setup-background-mining 1" to change.
Starting refresh...

and while it's starting a background refresh, but still not explicitly updating:

[wallet 42mEMY (out of sync)]: 
[wallet 42mEMY (out of sync)]: refresh
Starting refresh...
Error: refresh failed: unexpected error: proxy exception in refresh thread. Blocks received: 0
[wallet 42mEMY (out of sync)]: 
[wallet 42mEMY (out of sync)]: status
Refreshed 2688832/2891212, syncing, daemon RPC v3.12, SSL
[wallet 42mEMY (out of sync)]: 

Is this just how it goes with remote nodes?

2
  • from IRC it sounds like only version 0.18+ will fully sync and this one is old. May 22, 2023 at 17:43
  • 1
    You're using an outdated version and therefore the wallet will not sync yes. Please upgrade to the most recent version and try again thereafter.
    – dEBRUYNE
    May 22, 2023 at 19:00

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.