2

I have tried everything to get mining with my Nvidia GPU on Ubuntu 16.04 using ccminer. I've tried completely purging all drivers and dependencies and building from scratch, but I still have this issue, but when I try to run I get a "stack smashing detected" error:

richard@motherload:~/Apps/ccminer-cryptonight$ ccminer -o stratum+tcp://monerohash.com:3333 -u 49rGPcgztcd3ULhDSiao7AZh3666xfE3LTTWwUHXeqyJ37TmvtCWtcsCRqRs794HnKT3exyvoZ6hFTYgB3CD4x7y8dXH2Xg -p x
    *** ccminer-cryptonight for nVidia GPUs by tsiv ***
 based on ccMiner by Christian Buchner and Christian H.
 based on cpuminer-multi by LucasJones
 based on pooler-cpuminer 2.3.2 (c) 2010 Jeff Garzik, 2012 pooler
    BTC donation address: 1JHDKp59t1RhHFXsTw2UQpR3F9BBz3R3cs
    DRK donation address: XrHp267JNTVdw5P3dsBpqYfgTpWnzoESPQ
    JPC donation address: Jb9hFeBgakCXvM5u27rTZoYR9j13JGmuc2
    VTC donation address: VwYsZFPb6KMeWuP4voiS9H1kqxcU9kGbsw
    XMR donation address: 
      (man these are long... single address, split on two lines)
      42uasNqYPnSaG3TwRtTeVbQ4aRY3n9jY6VXX3mfgerWt4ohD
      QLVaBPv3cYGKDXasTUVuLvhxetcuS16ynt85czQ48mbSrWX
-----------------------------------------------------------------
*** stack smashing detected ***: ccminer terminated
Aborted (core dumped)

My video card is a GeForce GTX 580 (CUDA compute 2.0). I have the latest drivers installed from Nvidia. I have tried to use the --threads=1 flag to see if that would help, but no dice. I've also tried using CUDA 6.5 and CUDA 8.0. I am out of ideas.

0

It turns out that I was accidentally using the ancient and unmaintained tsiv branch of ccminer. When I had tried to install the KlausT version, it didn't overwrite this old version.

To solve this, I ran sudo rm /usr/bin/local/ccminer and re-cloned the KlausT branch of ccminer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.