1

I'v noticed that the current version of transaction in monero is now: vin, vout, extra, rct_signatures etc. My question is - when I run monero in testnet environment on my computer, the transaction include 'signature' field instead of the 'rct_sigantures' filed, and I'v try to figure out why is that. From the context of the code I understood that this difference caused by the 'version' field, but I don't understand when 'version' is changed, and if I can use the rct_signatures field from the start (height 0)

Thank you!!!

3

RingCT transactions are only activated at Monero version "4".

Take a look at testnet_hard_forks in blockchain.cpp, and you'll see that version 4 is configured to activate at block height 801219, and therefore you won't see rct_signatures until that block height.

  • Thank you very much!! I'v played a little with the block heights that change the versions, and than tried to make a transaction, but the transaction failed ("fee is too low", "not enough ring" etc)' or when it did work, the receiver didn't receive it. Can you please elaborate about the difference between the versions? what is the differnce between ver 1 and ver 2 and ver 4? – adsl Nov 4 '18 at 13:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.