1

So I have a fully synced v0.12.2.0 local Monero node running on my RPi. I am able to connect to this node through my Android Monerujo wallet over my WiFi. I am now trying to connect to this node via the v0.12.2.0 CLI wallet on Macbook. For this, I am running the command ./monero-wallet-cli --daemon-host 192.168.0.yy --wallet-file xxx. However, the CLI wallet is not able to connect to the local node and I see the message -

Starting refresh...
Error: refresh failed: no connection to daemon. Please make sure daemon 
is running.. Blocks received: 0

I tried using --daemon-address 192.168.0.xx:yyyy but faced the same result. I am running the local node with --confirm-external-bind parameter. Additionally, I am able to use the same Macbook to connect an Electrum wallet to my Electrum Personal Server running on another RPi indicating that there is no firewall issue. Any ideas what could be the problem?

I saw a similar post here but the accepted solution doesn't seem to work for me.

  • How did you launch monerod? Did your use a flag --rpc-bind-ip? – jtgrassie Jul 5 '18 at 1:12
1

By default, monerod binds to localhost. So no external connetion will reach it. You need to launch monerod with the flag --rpc-bind-ip=xxx.xxx.xxx.xxx to allow external connections. If you want to open to the outside world, that would be --rpc-bind-ip=0.0.0.0. Of course, you'd also need to ensure your firewall alowed incoming connections on port 18081 (unless you chaned the port via --rpc-bind-port, in which case your firewall should use the port you specified).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.