0

I've set up a monero-miner for my Raspberry Pi (for educational purposes) and when I run my miner deamon the log looks like:

[2018-06-28 07:58:10] Using JSON-RPC 2.0
[2018-06-28 07:58:10] CPU Supports AES-NI: NO
[2018-06-28 07:58:10] Starting Stratum on stratum+tcp://xmr.pool.minergate.com:45560
[2018-06-28 07:58:10] 4 miner threads started, using 'cryptonight' algorithm.
[2018-06-28 07:58:10] Binding thread 1 to cpu 1
[2018-06-28 07:58:10] Binding thread 0 to cpu 0
[2018-06-28 07:58:10] Binding thread 2 to cpu 2
[2018-06-28 07:58:10] Binding thread 3 to cpu 3
[2018-06-28 07:58:11] Pool set diff to 1063
[2018-06-28 07:58:11] Stratum detected new block
[2018-06-28 07:58:11] thread 1: 0 hashes, 0.00 H/s
[2018-06-28 07:58:11] thread 0: 0 hashes, 0.00 H/s
[2018-06-28 07:58:11] thread 3: 0 hashes, 0.00 H/s
[2018-06-28 07:58:11] thread 2: 0 hashes, 0.00 H/s
[2018-06-28 07:58:47] Stratum detected new block
[2018-06-28 07:58:47] thread 1: 0 hashes, 0.00 H/s
[2018-06-28 07:58:47] thread 2: 0 hashes, 0.00 H/s
[2018-06-28 07:58:47] thread 3: 0 hashes, 0.00 H/s
[2018-06-28 07:58:48] thread 0: 0 hashes, 0.00 H/s
[2018-06-28 07:59:17] Stratum detected new block

I know that the Raspberry Pi is not optimized for crypto mining but 5-20 H/s should be possible. To start my deamon I use

./minerd -a cryptonight -o stratum+tcp://xmr.pool.minergate.com:45560 -u <my address> -p x -t 4

as explained here: https://www.electromaker.io/tutorial/blog/cryptocurrency-mining-on-the-raspberry-pi-60

there it says:

To start mining Monero, run:

./minerd -a cryptonight -o stratum+tcp://xmr.pool.minergate.com:45560 -u youremail@address.com -p x -t 4

the money I mined is also not appearing in my wallet.. (neither on my MyMonero wallet nor on my MinerGate wallet)


What did I do wrong?

Any help is very appreciated

0

You probably using a XMR Address with the XMO pool port. Change your port to 45700

  • Edited my answer. give that a shot – Wesley Jun 28 '18 at 10:26
  • im not entirely sure what port it is, just scoped their website for a short period and noticed you had a XMO port in the perimeters – Wesley Jun 29 '18 at 7:07
  • port 45700 is correct but the miner is not mining at all... it only promts if a new block is found and if i run the miner for 1 hour all threads are at 0 hashes... – Fipsi Jun 30 '18 at 18:20
0

Finally solved it... I was using a 3-4 year old miner. The mining/hashing algo was changed in April (May?) I was using the old and incorrect miner, thus bad shares...

I installed a new miner: xmrig with the following commands:

apt-get install -y git build-essential cmake libuv1-dev libmicrohttpd-dev 
git clone https://github.com/xmrig/xmrig.git
cd xmrig
mkdir build
cd build
CFLAGS="-march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16 -O2 -pipe -fstack-protector-strong -fno-plt" CXXFLAGS="-march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16 -O2 -pipe -fstack-protector-strong -fno-plt" cmake .. -DWITH_HTTPD=OFF && make VERBOSE=1

Did this on a brand new Raspberry Pi 3B+ with armv7 CPU arch and new raspbian. Worked well. Getting about 9-10 H/s.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.