5

monerod v0.12.2.0 does not start on Linux because of "./monerod: error while loading shared libraries: libpcsclite.so.1". How do I resolve this particular issue?

5

This particular issue is resolved in CLI & GUI v0.13.

First, this error is caused by the libpcsclite dependency (which is required by Ledger) not being properly compiled statically. Fortunately, however, this error is trivially resolved by installing libpcsclite1. That is:

sudo apt-get install libpcsclite1

Fedora:

dnf install pcsc-lite

If, after installing this dependency, monerod still does not run and throws the same error, I'd recommend installing libpcsclite-dev (Ubuntu / Debian) or pcsc-lite-devel (Fedora)

Sources:

  1. https://www.reddit.com/r/Monero/comments/8ok4hg/v01220_binaries_released/e0e0zoq/

  2. https://www.reddit.com/r/Monero/comments/8ok4hg/v01220_binaries_released/e04w05u/

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.