I am getting an error building monero-stratum on macOS. cmake completes without error, but when I run make, I get the following error:

mac:monero-stratum powerkey$ make
Scanning dependencies of target cnutil
[ 20%] Building CXX object cnutil/CMakeFiles/cnutil.dir/src/cnutil.cpp.o
../monero-stratum/cnutil/src/cnutil.cpp:3:10: fatal error: 'cryptonote_basic/cryptonote_format_utils.h' file not found
#include "cryptonote_basic/cryptonote_format_utils.h"
1 error generated.
make[2]: *** [cnutil/CMakeFiles/cnutil.dir/src/cnutil.cpp.o] Error 1
make[1]: *** [cnutil/CMakeFiles/cnutil.dir/all] Error 2
make: *** [all] Error 2

I am following the instructions here. Monero 12.2 is installed and working.

I am using MacPorts instead of homebrew on macOS High Sierra (10.13.5) and Xcode 9.4.1 is installed if that changes anything.

  • Did you run MONERO_DIR=/path/to/monero cmake . before make? Reason I ask is the build is not finding monero source code.
    – jtgrassie
    Commented Jun 19, 2018 at 11:24
  • I did, and there are no errors or warnings. However, when I read your comment, I realized that my '/path/to/monero' was pointing to binaries, not source. That fixed it. Thanks.
    – Powerkey
    Commented Jun 19, 2018 at 17:10
  • 1
    Could you post that comment as an answer to your own question?
    – Endogen
    Commented Jun 20, 2018 at 20:19

1 Answer 1


My '/path/to/monero' was not correct. I was, incorrectly, pointing to monero binaries instead of source. Changing the path, to point to source corrects the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.