0

I am new at mining. My first experience is with monero with using xmr-stak on supportxmr pool. My problem is that when I mine with 4 cpu I get about 150 H/s. This is the default configs by the way, I mean when I compile the code, in the cpu file there is this:

"cpu_threads_conf" :
[
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 0 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 1 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 2 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 3 },

],

But when I increase these numbers (I got 4 core and 8 process, I am using ubuntu, when I open the system monitor I see 8 cpu) like below, I got more lower (about 60) H/s.

"cpu_threads_conf" :
[
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 0 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 1 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 2 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 3 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 4 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 5 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 6 },
],

This happens when tried it with 5,6,7 or 8 cpu. Why is that? Should not it increase when I increase the number of cpus?

One more question, actually I think I am mining with bot cpu and gpu, how can I check that if I am using gpu for mining or not? Thanks,

1

Whilst your CPU may have the ability to run 8 threads, it may not have enough cache for mining with 8 threads. With Monero, you need 2MB CPU cache per thread. So for 8 threads you'd need a CPU cache of 16MB available.

If you run more threads than you have cache for, it will slow down the hashing.

  • L1d cache: 32K L1i cache: 32K L2 cache: 256K L3 cache: 8192K This is my cpu cache informations. I guess it is 8MB is it right? So I can do mine with 4 thread max? – JollyRoger Jun 15 '18 at 16:13
  • You definitely don't have enough cache to mine effectively with 8 threads. Max for your CPU is 4 threads. – jtgrassie Jun 15 '18 at 16:23
  • Thank you for your answers. Can you say anything about my second question? And I would like to ask something else if you do not mind. I believe I get low hash rate (150), I got i7 8th gen intel cpu. I know I can not get much xmr with 1 cpu but I am just testing and learning the system. I guess I am missing some simple things to increase my hashrate. I did not do anything else than just setting up xmr-stak and run it. Can you suggest me something to increase hash rate other than overclocking? Thanks a lot, – JollyRoger Jun 16 '18 at 7:03
-1

You can log out of window manager,ssh or ALT + F7 into console and run xmr-stak from CLI ... Shave a few percent off your CPU load

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.