2

I started the monero daemon via the GUI on Mac OS X. I downloaded the binary unpacked from monero-gui-mac-x64-v0.12.0.0.tar.bz2.

When I do a simple $ ps aux | grep monero from the command line I get the following two entries:

/private/var/folders/p_/{really long random string}/T/AppTranslocation/{long random hex string}/d/monero-wallet-gui.app/Contents/MacOS/monerod --detach --data-dir /Users/{username}/Monero/blockchain --check-updates disabled

/private/var/folders/p_/{really long random string}/T/AppTranslocation/{long random hex string}/d/monero-wallet-gui.app/Contents/MacOS/monero-wallet-gui -psn_0_3179605

I was confused about this so I ran $ tail -f ~/.bitmonero/bitmonero.log and I found

WARN    daemon  src/daemon/executor.cpp:62  Monero 'Helium Hydra' (v0.11.1.0-release) Daemonised

This seems off since I downloaded version v0.12.0.0.

Some questions:

  1. Why the weird /private/var/folders/p_/ locations?
  2. If I want to run the monero daemon, should I run it from this weird folder location, or is there a better way?
  3. Should the daemon be on the same version as the GUI (v0.12.0.0) or is this an error?
  • The command line says the data directory is /Users/{username}/Monero/blockchain, and you say you check for the log in ~/.bitmonero. You're looking at an old log then. The log includes timestamps, double check those. – user36303 Aug 16 '18 at 15:51
0

Looks like you had a previous version already running. I would close your GUI, killall monerod, ensure there are none running with ps aux | grep monero, restart the GUI (which starts a daemon automatically).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.