0

I use the CLI wallet and I just noticed my wallet was out of sync by about 1000 blocks and wasn't syncing up. So I tried restarting and now every time I launch monerod it starts up and then shuts itself down. I tried poping some of the top blocks off at (least 10,000) and it doesn't seem to help. Here is a copy of the log when I start monerod.

  • 2018-05-06 17:47:45.435 3240 INFO logging contrib/epee/src/mlog.cpp:185 New log categories: *:WARNING,net:FATAL,net.p2p:FATAL,net.cn:FATAL,global:INFO,verify:FATAL,stacktrace:INFO,logging:INFO,msgwriter:INFO
  • 2018-05-06 17:47:45.435 3240 INFO global src/daemon/main.cpp:280 Monero 'Lithium Luna' (v0.12.0.0-master-release)
  • 2018-05-06 17:47:45.435 3240 INFO global src/daemon/protocol.h:53 Initializing cryptonote protocol...
  • 2018-05-06 17:47:45.435 3240 INFO global src/daemon/protocol.h:58 Cryptonote protocol initialized OK
  • 2018-05-06 17:47:45.435 3240 INFO global src/daemon/p2p.h:63 Initializing p2p server...
  • 2018-05-06 17:47:48.841 3240 INFO global src/daemon/p2p.h:68 p2p server initialized OK
  • 2018-05-06 17:47:49.388 3240 INFO global src/daemon/rpc.h:63 Initializing core RPC server...
  • 2018-05-06 17:47:49.388 3240 INFO global contrib/epee/include/net/http_server_impl_base.h:76 Binding on 127.0.0.1:18081
  • 2018-05-06 17:47:49.388 3240 INFO global src/daemon/rpc.h:69 core RPC server initialized OK on port: 18081
  • 2018-05-06 17:47:49.388 3240 INFO global src/daemon/core.h:86 Initializing core...
  • 2018-05-06 17:47:49.403 3240 INFO global src/cryptonote_core/cryptonote_core.cpp:427 Loading blockchain from folder C:\ProgramData\bitmonero\lmdb ...
  • 2018-05-06 17:47:51.482 3240 ERROR txpool src/cryptonote_core/tx_pool.cpp:398 internal error: kept_by_block=0, kei_image_set.size()=1
  • txin.k_image=<589e4db999ec0bec6371704072ba8b8eeaf10d932766ccd9e092bafd773ae0cd>
  • tx_id=
  • 2018-05-06 17:47:51.482 3240 FATAL txpool src/cryptonote_core/tx_pool.cpp:1280 Failed to insert key images from txpool tx
  • 2018-05-06 17:47:51.482 3240 ERROR cn src/cryptonote_core/cryptonote_core.cpp:513 Failed to initialize memory pool
  • 2018-05-06 17:47:51.482 3240 INFO global src/daemon/rpc.h:96 Deinitializing core RPC server...
  • 2018-05-06 17:47:51.482 3240 INFO global src/daemon/p2p.h:90 Deinitializing p2p...
  • 2018-05-06 17:47:52.653 3240 INFO global src/daemon/core.h:103 Deinitializing core...
  • 2018-05-06 17:47:52.919 3240 INFO global src/daemon/protocol.h:75 Stopping cryptonote protocol...
  • 2018-05-06 17:47:52.919 3240 INFO global src/daemon/protocol.h:79 Cryptonote protocol stopped successfully

I periodically export the blockchain as a backup about once a month. I was going to try to import from my backup, but when trying to import the --verify 0 command doesn't seem to be working now. Is there any way around this? I'm trying to avoid spending days re-syncing to the blockchain again.

  • --verify <= That was renamed to --guard-against-pwnage | In addition, to resolve your issue, it'd probably be best to load a backup of your blockchain. – dEBRUYNE May 6 '18 at 20:51
  • That is what I ended up doing. Thanks. – Samoflan May 7 '18 at 12:51

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.