1

I attempted to run the Monero RPC, but I am not able to connect to the daemon on either my VPS, which is running a synchronized daemon, or on my Windows PC. This is what happened

I started by running it on my ARM v7 VPS, which already has the daemon downloaded This is the command that I used to run the daemon

./monerod

After this synced, I ran

./monero-wallet-rpc --rpc-bind-port=18081 --wallet-file Webminer

RPC ends up displaying this

Monero 1

Then I tried to connect to a remote node, which failed so I did it on my one pc

Monero 'Helium Hydra' (v0.11.1.0-release) Logging to E:\Programs\Monero\monero-gui-win-x64-v0.11.1.0\monero-gui-v0.11.1.0\monero-wallet-rpc.log 2018-03-07 21:04:43.613 9148 WARN wallet.rpc src/wallet/wallet_rpc_server.cpp:1853 Loading wallet... Wallet password: ******** 2018-03-07 21:04:51.544 9148 WARN wallet.wallet2 src/wallet/wallet2.cpp:2505 Loaded wallet keys file, with public address: 488DS1c1SBfLr5L1JLCL7hKUTPCEiSVxuT7SkjkCzc7K8uRcjbi15S5Y2CLGcaszHQb31xcCQqShQDdHSymijyBkMXvPKMQ 2018-03-07 21:04:52.761 9148 ERROR net.http src/wallet/node_rpc_proxy.cpp:82 Failed to connect to daemon 2018-03-07 21:04:52.761 9148 ERROR wallet.wallet2 src/wallet/wallet2.cpp:1190 result->empty(). THROW EXCEPTION: tools::error::no_connection_to_daemon 2018-03-07 21:04:52.762 9148 WARN net.http src/wallet/wallet_errors.h:707 C:/msys64/DISTRIBUTION-BUILD/src/wallet/wallet2.cpp:1190:N5tools5error23no_connection_to_daemonE: no connection to daemon, request = getversion 2018-03-07 21:04:52.762 9148 ERROR wallet.rpc src/wallet/wallet_rpc_server.cpp:1887 Wallet initialization failed: no connection to daemon

Thank you!!

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.