1

I have a monerod daemon running on a PC (IP 192.168.1.150) and a wallet running on another PC. Sometimes all works, sometimes not and shows:

Error: wallet failed to connect to daemon

I use these commands to launch the programs:

./monerod --rpc-bind-ip 192.168.1.150 --confirm-external-bind

./monero-wallet-cli --daemon-address 192.168.1.150 --wallet-file walletname

So, is there a way to check the connection between daemon and wallet?

  • Perhaps try binding to 0.0.0.0? It's probably a good idea then to add the --rpc-login flag too (use monerod --help & monero-wallet-cli --help to see the specific parameters and arguments) as well as the --restricted-rpc flag. – dEBRUYNE Feb 2 '18 at 12:24
  • Not works. I have checked the wallet log, found this: 02-02 16:13:35.401 7f8ccd227b80 ERROR net.http contrib/epee/include/net/http_client.h:444 Unexpected recv fail 02-02 16:13:35.401 7f8ccd227b80 ERROR wallet.wallet2 src/wallet/wallet2.cpp:1216 !r. THROW EXCEPTION: error::no_connection_to_daemon 02-02 16:13:35.401 7f8ccd227b80 WARN net.http src/wallet/wallet_errors.h:707 /DISTRIBUTION-BUILD/src/wallet/wallet2.cpp:1216:N5tools5error23no_connection_to_daemonE: no connection to daemon, request = getblocks.bin – cialu Feb 2 '18 at 16:50
  • @dEBRUYNE I did several attempts with different combinations of parameters, all fail. I also deleted the blockchain and synced it again, the same result. The wallet reaches the daemon, but it still not working. Maybe, should I open an issue on GitHub? – cialu Feb 3 '18 at 10:06
  • That seems like a good idea. Although, it should be noted that your issue is likely caused by idiosyncratic factors. – dEBRUYNE Feb 3 '18 at 18:48
2

With the new 0.13.0.4 Beryllium Bullet version of the daemon and CLI software, all is working fine under Linux. No more issues.

| improve this answer | |
0

Try with this command:

./monero-wallet-cli --daemon-host 192.168.1.150 --wallet-file walletname

This seemed to work for me.

| improve this answer | |
  • 1
    The same result, I'm thinking at issue related to my LAN. If I did nmap -p 18081 192.168.1.150, I get 18081/tcp open and also DNS resolution is fully working, so I don't understand the problem. – cialu Feb 2 '18 at 8:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.