2

I am currently running Ubuntu 16.04 server with monero-v0.11.1.0. I successfully downloaded the live chain without problem. When I tried to download the testnet chain I get over and over:

2018-01-30 03:31:18.531 [P2P2]  WARN    net.p2p src/p2p/net_node.inl:759        [212.83.175.67:28080 OUT] COMMAND_HANDSHAKE invoke failed. (-4, LEVIN_ERROR_CONNECTION_TIMEDOUT)
2018-01-30 03:31:18.531 [P2P1]  WARN    net.p2p src/p2p/net_node.inl:808        [212.83.175.67:28080 OUT] COMMAND_HANDSHAKE Failed

I wanted to set up a test wallet to program and do testing with fake coin. Is there a way around this?

Also the command I am using is

./monerod --testnet --log-level=1

I wanted to use an rpc wallet for a website to accept monero as hobby project :)

3

You need a more recent version to use the public testnet. In particular, the public testnet is currently running v7, while 0.11.1.0 only knows up to v6. At some point, the testnet will also be reorganized as bulletproofs will be moved to v8, and v7 will be re-mined, so be aware that coins you mine on testnet on v7 will go poof at some point.

  • I will download from github today the source and try it out – Anekdotin Jan 30 '18 at 15:38
  • 1
    Thank you. I complied monero from source, installed the requirements. Then testnet worked great. The official download doesnt support testnet. – Anekdotin Jan 30 '18 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.