3

I am trying to configure an older mining rig I built about four years ago for Dogecoin into a Monero mining rig. I have a bunch of different Radeon cards, but right now, I just want to get two R9 290x's working on Ubuntu 16. I have down over a dozen re-installs of the OS trying to get it right---was so much easier with fglrx and Ubuntu 12. I tried Ubuntu 14 and fglrx (and found a nice guide about downgrading Xorg components) but still no go. I was able to get the mesa open source drivers working with xmr-stak, but I have a super low hash rate for each card (~150 H/s). What's wrong with my steps below for configuring an XMR miner with R9 290x's?

  1. Install Ubuntu 16 from CD. Didn't choose any third-party installs during setup.
  2. Downloaded and installed AMDGPU-PRO drivers for R9 290x and Ubuntu 16.
  3. Disabled radeon modules in GRUB, updated, etc.

*** After this step, I typically did not see the AMDGPU drivers in use when I ran lspci ****

  1. Downloaded and installed AMD SDK per instructions on xmr-stak compilation guide.

  2. clinfo and xmr-stak dump and/or can't find OpenCL platform. More commonly, there were no IDs returned for the cards that were connected.

I've tried these steps with one card connected or two. Many thanks in advance for any suggestions!

3

I was struggling too with 290x. Currently I am unable to overclock...but at least I got it up and running.

1) Ubuntu 16.04
2) AMD-APP-SDK-v3.0.130.136-GA-linux64.sh - install it, reboot
3) amdgpu-pro-17.40-483984.tar.xz drivers - install it, reboot
4) /etc/default/grub change GRUB_CMDLINE_LINUX_DEFAULT="amdgpu.vm_fragment_size=9"
5) cp /opt/amdgpu-pro/lib/x86_64-linux-gnu/libOpenCL.so.1 /usr/lib/libOpenCL.so.1
6) Clone sgminer-gm and install all needed deps.
7) Go to sgminer folder

autoreconf -fi
CFLAGS="-Os -Wall -march=native -I/opt/AMDAPPSDK-3.0/include" LDFLAGS="-L/opt/amdgpu-pro/lib/x86_64-linux-gnu" ./configure --disable-git-version
make

I hope this helps. In any case you should see, if it ends with _CPU then something is still wrong.

clinfo | grep Type
  Device Type:                                   CL_DEVICE_TYPE_GPU

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.