2

So today I decided to check my offline wallet and make some donations.

Fire up monero-wallet-cli on the hot machine, connect to monerod and do the usual:

export_outputs outputs

Then I move that outputs to the offline machine, start monero-wallet-cli and do:

import_outputs outputs

All I get is: "Failed to import outputs: Transaction extra has unsupported format at index 17"

So I tried to rescan_bc on the hot wallet and no chance, the outputs still can't be imported. Now both the hot and cold wallet are showing different balances because outputs can't be imported and I believe my wallet is unusable now that UTXO aren't properly tracked in the hot wallet. I have already tried to export key images and importing to hot wallet anw in case that error is just a warning but the balances shown still differ.

Monero version: 0.11.1.0 for Linux 64bit.

OS of monerod: ArchLinux, updated a few minutes ago.

OS of monero-wallet-cli: Fedora-25 guest inside QubesOS 3.2.

Is there a way to fix this?

2

It should be fixed one this PR is merged: https://github.com/monero-project/monero/pull/3065

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.