1

I have just set up cpuminer-multi on my Raspberry Pi B+, my aim is to mine a cryptonight coin called Bytecoin. Instead of connecting the mining Pi to the pool, I will be connecting the mining Pi to a proxy which is connected to the pool, so that I can mine with more than one Pi.

I did this by doing the following...

# update raspbian
sudo apt-get update -y

# install the following dependent modules
sudo apt-get install autoconf libcurl4-openssl-dev libjansson-dev openssl libssl-dev gcc gawk

# clone this miner repo
git clone https://github.com/lucasjones/cpuminer-multi.git

# navigate to the directory and compile
cd cpuminer-multi
./autogen.sh
./configure
make

But When I enter the following code to start the miner...

 ./minerd -a cryptonight -o pool.bytecoin.party:3333 -u (My Bytecoin Address Was Here) -t 1

I get the following error...

[2018-01-08 21:40:07] Using JSON-RPC 2.0
[2018-01-08 21:40:07] CPU Supports AES-NI: NO
[2018-01-08 21:40:07] 1 miner threads started, using 'cryptonight' algorithm.
[2018-01-08 21:40:07] HTTP request failed: Empty reply from server
[2018-01-08 21:40:07] getwork failed, retry after 10 seconds

I have even tried setting up a proxy on another Raspberry Pi that connects to the pool, but when I try to connect the mining Raspberry Pi to the proxy Raspberry Pi, I get the same error.

I tried to see if the miner will mine any other cryptocurrencies, so I initiated scrypt mining to my Litecoin pool and that worked well.

I am unsure about how to fix this, any help or suggestions will be much appreciated,

Thanks!

Sid

  • While I'm not trying to dissuade you from bytecoin per se, make sure you are familiar with the asserted background that the devs premined 82% of the coins in advance. It is one of the reasons Monero is such a success and many of the active enthusiasts abandoned bytecoin. Do a little reading then make your own decision of course. Here's a reference: ccn.com/… – Mark Jan 9 '18 at 11:25
1

Your pool uses the stratum protocol instead of the older getwork protocol that cpuminer-multi defaults to. Use -o stratum+tcp://pool.bytecoin.party:3333.

I'd also recommend switching to xmrig since cpuminer-multi has been dead for a while.

0

There is something wrong with your mining-pool. I recommend to try another pool. Take a look at Coinfoundry. Fee is 0.15% and other then that you don't need to pay anything else.

The URL is: xmr.coinfoundry.org:3032

And please use xmrig instead of minerd

BTW: If you are mining on an raspberry pi, don't mine Monero. Not even slightly enough hashing power. Take a look at mining Electroneum (ETN). Coinfoundry has a pool for that also.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.