Hi I'm on a Mac and am upgrading my monerno CLI wallet version to v0.11.1.0. I copied the guide here how to upgrade monero wallet to v0.11.1.0 but when I type this on terminal window ./moneroD I get this error message:

-bash: ./moneroD: Permission denied

When I try to override it using sudo ./moneroD I get this: sudo: ./moneroD: command not found

How do I fix this?

  • To be clear, the old version worked? Also, is that capital D intentional?
    – dEBRUYNE
    Commented Dec 25, 2017 at 9:25
  • Yes the old version worked. Yes D is intentional copied instructions online Commented Dec 29, 2017 at 0:09
  • Could you try without the capital D then?
    – dEBRUYNE
    Commented Dec 30, 2017 at 14:30

1 Answer 1


Permission denied is typically due to... bad permissions, unsurprisingly. You need at least execute permission (for owner if you own the file, for group if you're on its group, others otherwise).

Here, sudo fixes it, so it's likely you don't have read rights on the directory. Fix that. You probably saved this as root, which is a bad idea in the first place. chown will help here (chown user.group monerod, replacing user and group with your own).

Next, command not found means just that. There's probably no moneroD binary in the . directory. Typically, monerod is called monerod, not moneroD. Double check its name.

Last, if there really is a moneroD, then it might be the wrong excutable format (eg, 64 bit if you're on a 32 bit machine, etc). Double check you got the right binary format.

Anyway, this is a UNIX usage question, not a Monero question, so if further help with this problem is needed after those things are checked, you will be better off asking a UNIX/Mac stack exchange (assuming any further problems aren't Monero ones).

  • Thanks. I figured out that when i unzipped the files it keeps unzipping the binary files as text files. Commented Dec 29, 2017 at 0:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.