1

I am trying to compile monero on ubuntu 16 LTS, but i get the following compilation error (see screenshot), I am running the Linux machine in esxi hypervisor (virtual machine). It seems there is an issue with the assembler?

enter image description here

  • Are you trying to build on a i686 Linux platform ? – Zigglzworth Dec 22 '17 at 22:41
  • yes, giving lscpu shows it is i686, 32 and 64 bit – Drl Sherif Omran Dec 23 '17 at 9:49
  • Are you sure you are using downloads.getmonero.org/cli/linux32 ? – Zigglzworth Dec 23 '17 at 10:08
  • Wait a minute.. are trying to build Monero or Cpuminer-multi ? – Zigglzworth Dec 23 '17 at 10:16
  • i tried to compile monero but it did not work, then i tried to compile cpuminer multi, which also did not work. Now i managed to get it to work, with ./configure using a parameter i found online. – Drl Sherif Omran Dec 23 '17 at 11:35
1

worked with the following ./configure CFLAGS="-march=native" --with-crypto --with-curl

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.