1

I have a problem. I made it with this tutorial http://fucking-it.com/articles/bitcoin/771-monero-cpu-mining-on-linux

In the last step I get this message CPU does not have AES-NI, which is required.

What do I do with this?

  • Use JCE miner. It supports non-AES CPUs – Djago Oct 24 '18 at 22:53
2

You can't efficiently mine using a chip that doesn't support AES-NI.

Verify that the current CPU has the AES instruction set using the following command:

grep -m1 -o aes /proc/cpuinfo

If it supports AES-NI, your output will be "aes" . If it doesn't output anything, you can't mine on your Raspberry Pi using cpuminer.

  • I got nothing. What shloud I do now? Mining on raspberry pi? – Paul Dec 18 '17 at 20:34
  • That means u cant mine on your Pi. But pi have a GPU u can utilize that. I couldn't find any tools online. Even though if u code one script the hashrate will be terribly low as < 1 H/s – Susmith Dec 19 '17 at 7:01
  • Ok, I understand – Paul Dec 19 '17 at 7:07
  • You can try using a different miner. I got this error with CPUMiner-Multi, but the same computer works with minergate-cli. – Keith Mar 28 '18 at 18:24
1

What is the CPU in your system?

That miner is no longer supported.

Perhaps use this this: CPUMiner-Muli

Read the build instructions to build it for your *nix

Basic instructions:

Download the miner
$ git clone https://github.com/tpruvot/cpuminer-multi

If using Ubuntu do
$ apt-get install automake autoconf pkg-config libcurl4-openssl-dev libjansson-dev libssl-dev libgmp-dev make g++

$ cd cpuminer-multi

$ ./build.sh

$ make install

See what your options with
$ cpuminer --help

Usually you would do something like
$ cpuminer -t 2 -a cryptonight -o stratum+tcp://whateverpool.com:0420 -u youraddresshere -p x
  • ok, thank you for your help, but I do not know what I should do. It is my first time when I do it. Can you explain me well what I should do? – Paul Dec 17 '17 at 22:46
  • I added some basic instructions but didn’t test them so comment on any corrections you discover – Zigglzworth Dec 17 '17 at 23:06
  • I did everything as you and I got this massage: cpuminer: command not found – Paul Dec 17 '17 at 23:19
  • Are you sure it built ok? Are you in the correct directory where cpuminer is? ./cpuminer —help – Zigglzworth Dec 17 '17 at 23:23
  • Yes, when I build it I got this: make[2]: Leaving directory '/root/cpuminer-multi' make[1]: Leaving directory '/root/cpuminer-multi' – Paul Dec 17 '17 at 23:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.