I've installed this recent unified miner called xmr-stak and in the first time I used I mine on xmrpool.net, now I want to mine on xmrpool.eu. If I run the program with no parameters, it doesn't show me option to set the target pool and just choose the previous configured (.net), if I run with parameter -o xmrpool.eu:3333 it shows:

[2017-12-15 21:23:17] : Fast-connecting to xmrpool.net:3333 pool ...

[2017-12-15 21:23:17] : Fast-connecting to xmrpool.eu:3333 pool ...

So my question is, how to reset these config so it doesn't connect to the old pool?

2 Answers 2


1) Edit the config.txt file by changing the "pool_address" field in the "pool_list" section. You could also have a list of additional pools and adjust the weights as you wish (e.g. mentioning some backup options).


2) Delete the config.txt file. Next time you run the executable it will ask you to set the target pool as it did on the first run (it will also ask for the rest of configs as it did then).


I think there’s a config.tpl file where you can set the pool address

The pool address must be in the form "pool.supportxmr.com:3333" and only stratum pools are supported

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.