I changed from windows to Ubuntu 17.10 Linux. I'm totally new on it. I've been learning how to work with the terminal, and I have already downloaded my old windows blockchain.raw file located in the my download files. When I try to open the monerod.exe, nothing happens. I open up the GUI and it starts from scratch. I opened


And the monero-blockchain-import.log says the following:

lmdb/db_lmdb.cpp:2674 WARNING: batch transaction mode already enabled, but asked to enable batch mode 2017-12-03 23:13:33.979 7f1e57c56f00 FATAL bcutil src/blockchain_utilities/blockchain_import.cpp:229 bootstrap file not found: "/home/lh1008/.bitmonero/export/blockchain.raw"

I went to my "home directory" and can't find anywhere the .bitmonero export directory. Through the terminal I ran the command to prompt monero-blockchain-import to the download directory where I have the blockchain.raw file but the terminal gave me an answer that "monero-blockchain-import doesn't exist". Have tried several times, read the manual for help but I can't find my error. I can run from scratch the node but I also want to learn how to do it properly. I will really appreciate any help.

Can anyone help?

Thanks :)

2 Answers 2


You can put this file anywhere, you just need to add --input-file XX and put the file and its path instead of XX, eg:

monero-blockchain-import --input-file $HOME/blockchain.raw

As for "monero-blockchain-import doesn't exist" errors, this is unrelated, and just means monero-blockchain-import is not in your PATH environment variable. Either add its directory to your PATH, or give the whole path to it (either relative or absolute), eg:

./monero-blockchain-import --input-file $HOME/blockchain.raw

if it's in the current directory, or maybe:

build/release/bin/monero-blockchain-import --input-file $HOME/blockchain.raw

if you've just built it.


I was not able to find the .bitmonero directory in the /home folder and was not aware that "." folders are hidden. So I searched for help in the Ubuntu community and found this answer How to show a hidden file. It was easy, stand in the home directory and put this command:

cmd/ctrl + H

Then, the .bitmonero directory showed up.

This answer might help anyone. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.