1

I am really new to this world so please apologies if that's a stupid question. I have generated my monero wallet with this tool: https://moneroaddress.org/ And kept al the information somewhere in a file I encrypted. I have started using xmr-stack to "mine". When I started xmr-stack it asked me for the pool address (I'm mining on monerohash) and my wallet I wanted to use. things seems to be working (at least I can see no errors) but to be very honest, I have no idea what I'm really doing here. From What I read I can check my wallet using monero-wallet-cli. So I installed and sync'd monerod and then tried to use the wallet cli. but It seems it's willing to created a new wallet.

Can I import the wallet I created before? If yes, then how? Am I doing anything stupid here?

Thanks

1

You need to run:

monero-wallet-cli --restore-deterministic-wallet

You will be asked for the seed you created earlier.

You will need a running daemon (monerod), which may be one of the public ones or your own, in order to download the blocks to see your transactions. When asked for a refresh height or date, make sure you put one that's when you created your wallet originally.

  • Thank you it seems that worked. However my balance is still at 0: Balance: 0.000000000000, unlocked balance: 0.000000000000 is it normal after a few days of mining (even though I have a terrible hash rate ~ 50 H/s)? – alxgomz Dec 9 '17 at 14:53
  • If you're solo mining, it's normal, it's a lottery for all intents and purposes. If pool mining, that's probaly normal, most pay out when your dues reach half a monero (you can check your pending balance on the pool using your address). – user36303 Dec 9 '17 at 20:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.