1

When I run monerod on a background fork in linux, it always stops after sometime. Why is this? I have tried using monerod --detach and nohup monerod & and it still stops after awhile. I can't complete a full sync as a result. Does anyone know why this is happening ?

  • Give the version of monerod you're using, and whether you're getting an OOM kill (check dmesg). – user36303 Dec 2 '17 at 19:57
  • monero-v0.11.1.0 but I solved the problem. Was caused becuase it was running on a child process from a remote shell – Zigglzworth Dec 3 '17 at 10:13
  • 1
    Alright. Feel free to add this as an answer, and accept it, it might help someone later on :) – user36303 Dec 3 '17 at 13:50
2

This ended up being because I was running monerod on a child process via remote shell in which case one should use screen to keep the process running should there be a disconnection or run on a system owned background process

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.