I have built the application from source on ubuntu 16.04

I started the daemon /usr/local/bin/monerod in one shell and it seems to run fine:

enter image description here

Then in another shell, I tried to run the monero-wallet-cli, and it is what I see:

$ /usr/local/bin/monero-wallet-cli
Monero 'Helium Hydra' (v0.11.0.0-8512a83)
Logging to /usr/local/bin/monero-wallet-cli.log
Specify wallet file name (e.g., MyWallet). If the wallet doesn't exist, it will be created.
Wallet file name (or Ctrl-C to quit): first
Wallet and key files found, loading...
Wallet password:
Opened wallet: 45yY5AD8KXXXXXXXLtgPke
Use "help" command to see the list of available commands.
Use "help <command>" to see a command's documentation.
Starting refresh...
Error: refresh failed: internal error: Daemon claims reorg below last checkpoint. Blocks received: 0
Background refresh thread started
[wallet 45yY5A (out of sync)]: 
[wallet 45yY5A (out of sync)]: 
[wallet 45yY5A (out of sync)]: 

Is it a problem? What do I need to do to fix it?

I tried refresh at the prompt and I got exactly the same error message

enter image description here

1 Answer 1


The daemon tells the wallet that the wallet should be looking for a top block of 1,445,692 (per the daemon log snippet). The wallet, therefore, knows that it is not in sync with the blockchain. The wallet will only be confident in its balance and allow you to spend those funds once it thinks it is fully synced.

You might as well wait until the daemon is fully synced before opening up the wallet. Alternatively, you could open the wallet with the --daemon-host flag. This answer details several ways of operating a wallet without downloading the blockchain.

Note that running a full node is encouraged, particularly in the case of Monero, to have the highest likelihood of privacy and least need to trust others.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.