2

I am getting this error when trying to run Monero Wallet from www.getmonero.org on my Ubuntu machine:

$ ./start-gui.sh

./monero-wallet-gui: error while loading shared libraries: libxcb-glx.so.0: cannot open shared object file: No such file or directory

I have downloaded the "monero-gui-v0.11.1.0" wallet. I tried this with both 32 and 64 bit version. I also installed all the required dependencies listed on https://github.com/monero-project/monero The Ubuntu system details are:

Description: Ubuntu 16.04.3 LTS

Linux pc 4.4.0-98-generic #121-Ubuntu SMP Tue Oct 10 14:24:03 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Any help on this matter is appreciated.

Thank you.

  • try: ldd monero-wallet-gui | grep xcb then it if shows a filename, try: file INSERTTHATFILENAMEHERE – user36303 Nov 7 '17 at 16:32
  • This is what I am getting: $ ldd monero-wallet-gui |grep xcb libxcb-glx.so.0 => not found libX11-xcb.so.1 => not found libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xf7730000) $ file /usr/lib/i386-linux-gnu/libxcb.so.1 /usr/lib/i386-linux-gnu/libxcb.so.1: symbolic link to libxcb.so.1.1.0 – Dark Templar Nov 8 '17 at 8:23
  • You have 32 bit libs. Make sure you get a 32 bit monero-wallet-gui, and try again. – user36303 Nov 8 '17 at 10:05
  • I checked again and get the same error with 32 bit too. The cli version although does not complain. How do I make the GUI work too? Thanks. – Dark Templar Nov 8 '17 at 10:53
  • If you still get a libX11-xcb.so.1 not found, you need to install libX11-xcb.so (which I think ought to be installed already, but just in case). If it doesn't help, look for libX11-xcb.* on your disk, and run file on it. – user36303 Nov 8 '17 at 19:29
1

I had the same error on a 64 bit system and could get rid of them via:

sudo apt install libxcb1:i386 libx11-xcb1:i386 libxcb1:i386 libxcb-glx0:i386 libfontconfig:i386 libx11-data:i386 libx11-xcb1:i386 libx11-6:i386 libxext6:i386

But afterwards still a segfault happens - seems that the monero wallet gui is not (yet?) compatible with 64 bit systems.

| improve this answer | |
  • That's really fishy. Are you using a 32 bit binary somehow ? – user36303 Mar 29 '18 at 9:08
  • yes, there does not exist a 64 bit binary for monero-wallet-gui at this time, I thought I could run the 32 bit binary on a 64 bit machine – Aydin K. Mar 29 '18 at 10:11
  • I've been running on a 64 bit machine ages ago. If they don't supply a ready made binary for your particular arch, you can build it yourself, it works fine. – user36303 Mar 29 '18 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.