1

I have compiled xmr-stak-nvidia on Ubuntu 17.10 with latest Nvidia driver and Cuda 9.0. If I try to run it, I get some issues:

[2017-10-21 11:18:36] : Connecting to pool xxxxxxxxxx:3333 ...
Driver does not support CUDA 8.0 API! Update your nVidia driver!
[2017-10-21 11:18:36] : Setup failed for GPU 0. Exitting.

Any idea to solve it?

2

You have to use CUDA 9. Get it via: wget https://developer.nvidia.com/compute/cuda/9.0/Prod/local_installers/cuda_9.0.176_384.81_linux-run and then run sudo sh cuda_9.0.176_384.81_linux.run. Make sure it is correctly installed. You have to run the script multiple times!

The error seems like you haven't installed cuda 9. Run the install script and read the output. If it's not installed it's likely because you have cuda 8 installed. Therefore remove all cuda files/installs with sudo apt remove --purge nvidia* Then check /usr/local/cuda* and remove it if necessary. After this try to install cuda 9 with the steps from above.

The only way to compile and run it with Ubuntu 17.10 for me was using clang 3.8 and cuda 9.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.