1

I'm not the most tech savvy guy, but I can get around if instructed properly. I downloaded the GUI wallet and when I start the Daemon, it reflects as being connected. However, when I look in the log, there is a recurring error that says "failed to connect to seed peers, continuing without seeds".

It's been two days since I sent the transaction to my wallet, and it still isn't showing up. I even tried connecting to a remote node, which did seem to sync the blockchain, but my funds still aren't showing up. When I'm connected to the remote node, I still get the "failed to connect..." error.

I've confirmed that the address is correct. Can someone help me?

2

You need two things:

  • a synced daemon ("status" in monerod should show 100%; using a remote daemon should normally be fine)
  • a refreshed wallet (it'll scan the blockchain monerod downloaded/verified in order to check whether any changes in your account occured)

The seed connection error is only fatal on the first connection. If it manages to connect once to a seed, it'll learn of other peers on the Monero network, and then be able to connect to them. If this is your first connection, then a seed is needed to bootstrap. Check you have internet connectivity on the VM/machine running monerod, and check port 18080 is usable (sometimes firewalls block ports which aren't known to be needed default).

  • How can I confirm that the daemon is synced? My Network status shows as connected. Also, I tried opening monerod, I get the black screen, some script runs and then it closes down, but at some point there was some red text and looks like an error, but i don't have enough time to read it before it closes. How can I scan the blockchain? – Filipe Oct 21 '17 at 0:07
  • Ok, i figured out that I have to exit out of the GUI to use Monerod. But, now that I can run Monerod, I still get the "failed to connect to seeds error". – Filipe Oct 21 '17 at 0:22
  • Do I have to go into the GUI, set the remote node, save it, then exit out and run monerod? Any guidance would be super helpful. Like I said, this is my first time using this wallet and I could use some guidance. – Filipe Oct 21 '17 at 0:49
  • You can either use a remote node, or your local one. So no to "Do I have to go into the GUI, set the remote node, save it, then exit out and run monerod?". I would (1) exit GUI, (2) run monerod. Then you'll see any errors beyond the seed messages. After running monerod, wait 20 seconds, then run "print_cn". If you have no connections, or if all show a 0000000000000000 in the second column, then you can't connect to the network and the seed problem is a real one. In that case, check firewall, etc. – user36303 Oct 21 '17 at 8:07
  • user36303, I used the "print_cn" command. I'm showing several connections listed, but the second column "Peer ID" everything shows as 0. Also, "recv" is showing as 0. State = "state_befr_handshake". Down = 0 Up = 0. I've checked the firewall and made an exception in and out for Port 18080.... What else can I do? – Filipe Oct 21 '17 at 21:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.