3

I am running a clean install of Monero client for Linux 64bit, binaries as available on 13-oct-2017, v0.11.0.0

I have deleted previous client, and ~/.bitmonero. I am importing an older wallet file though.

The blockchain synched for a few hours, but now whenever I run monerod it simply seg faults.

I have tried with monerod --block-sync-size=1 --max concurrency 1 but it still just dumps with a segmentation fault.

Any advice on how to fix this? Thankyou.

  • Could you help out w/ debugging? github.com/monero-project/monero#debugging – dEBRUYNE Oct 14 '17 at 0:25
  • yes sure thing, very happy to help support monero. Just let me know what you need. FYI I just compiled fresh from github and it is syncing. – Mtl Dev Oct 14 '17 at 0:47
  • Just FYI: tried a manual import of blockchain.raw before this, that too failed with error 2017-10-14 00:46:55.545 7f727ffbe740 ERROR bcutil src/blockchain_utilities/blockchain_import.cpp:772 Exception at [Import error], what=Aborting – Mtl Dev Oct 14 '17 at 0:49
  • do you want the stack trace from gdb? – Mtl Dev Oct 14 '17 at 0:54
  • 1
    Confirmed: resolves issue. Thankyou. Suggest: this patch should make it into the publicly available monero binaries as a matter of priority, to ensure a good end user impression. Compiling from source while trivial for those who know, is in practice simply out of reach of the many. – Mtl Dev Oct 14 '17 at 14:06
3

This crash was fixed in https://github.com/monero-project/monero/pull/2492, and you can merge it to your tree with the following commands:

git checkout -b crash-fix
git fetch origin pull/2492/head:2492
git cherry-pick 2492

You're now on a branch with whatever source you had before, plus the crash fix. You can now compile normally.

When you want to get back to master (ie, to pull latest):

git checkout master

| improve this answer | |
  • Thankyou. FYI this crash occurs on the downloadable binaries from getmonero.org. Confirming building from source with current master resolves the issue. – Mtl Dev Oct 14 '17 at 9:24
  • There will likely be a 0.11.0.1 soon to get those fixes in. – user36303 Oct 16 '17 at 10:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.