2

enter image description hereSince the last fork, I have been unable to sync my monero nodes. I have tried from multiple machines and redownloaded the blockchain entirely, However, I still get the following results.

Is anyone familiar with this? The mounted drive has 500+GB free space on NTFS partition.

Thanks! The picture taken is of my monitor with error showing.

src/blockchain_db/lmdb/db_lmdb.cpp:72 Failed to commit a transaction to the db: Operation not supported src/cryptonote_core/blockchain.cpp:3598 Exception in cleanup_handle_incoming_blocks: Failed to commit a transaction

1

The default ntfs driver in Linux doesn't support writes. NTFS support on Linux is generally pretty awful.

  • On my Ubuntu Laptop, I run into the same error though. This is one reason I moved to raspian. Is the root of the issue a corrupt DB in both cases? I would think so but the chances would be slim I would have thought.. – Jonathan Hicks Sep 28 '17 at 1:21
  • There's no DB corruption here at all. Your OS doesn't support NTFS in read/write mode. Use ext4 or xfs instead. – hyc Sep 28 '17 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.