1

This question already has an answer here:

  1. I used monero-wallet-gui to import a paper wallet. Synchronization started from the beginning.

    1. Synchronization ran very fast and perfectly well until the moment when my funds appeared, more or less (between "Blocks remaining: 5500" and "Blocks remaining: 4000).

    2. However, from that moment on, synchronization slowed down very much and, worse, the number of blocks remaining started slowly increasing, not decreasing.

    3. Being a Mac user (OS X Yosemite, 10.10.5), I followed the instructions that I've found here: My blockchain is stuck, how do I "unstuck" it?

    4. More specifically,

a) After rebooting my Mac and before starting the GUI, I deleted the p2pstate.bin file. This did not help: the number of blocks remaining was still increasing.

b) So I stopped the daemon and I added "--block-sync-size 20" as daemon startup flag. I then restarted the daemon. This also did not help: the number of blocks remaining was still increasing.

c) So I checked bitmonerolog and I noticed this message: "cryptonote_core/cryptonote_core.cpp:1123 [1;31mLast scheduled hard fork time shows a daemon update is needed now". In fact, I noticed that my monero.wallet.gui version was 0.10.3.1 while the current version is 0.11.0.0

Question: any ideas on how to solve the problem? Does 5.c above is the problem? I'm downloading the new version of the GUI. Will keep this question updated.

YES! 5.C was the problem. After downloading the new version of the GUI synchronization seem to work fine: "Blocks remaining" number started decreasing again.

Have a nice day :-)

marked as duplicate by dEBRUYNE, assylias, 254123179 Jan 25 '18 at 4:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

The problem was solved by updating the GUI to the latest version.

Not the answer you're looking for? Browse other questions tagged or ask your own question.