0

Monerod was working correctly, but suddenly stopped. I tried downloading the latest version (monero-gui-0.11.0.0) in the hopes that that would solve the problem, but it doesn't. When I try to start the program through the terminal rather than via the GUI, I am told the program doesn't exist even though the ls command shows it very clearly.

I am running Ubuntu 14.04, and was doing so when it worked correctly earlier.

The bitmonero.log says: 2017-09-14 10:57:06.331 7f1519564780 INFO logging contrib/epee/src/mlog.cpp:148 New log categories: *:WARNING,net:FATAL,net.p2p:FATAL,net.cn:FATAL,global:INFO,verify:FATAL,stacktrace:INFO,logging:INFO,msgwriter:INFO 2017-09-14 10:57:06.331 7f1519564780 ERROR msgwriter src/common/scoped_message_writer.h:102 Error: Couldn't connect to daemon: 127.0.0.1:18081 And the monero-wallet-gui. log says: 2017-09-14 10:56:52.394 7fab3bc417c0 INFO logging contrib/epee/src/mlog.cpp:148 New log categories: *:WARNING,net:FATAL,net.p2p:FATAL,net.cn:FATAL,global:INFO,verify:FATAL,stacktrace:INFO,logging:INFO,msgwriter:INFO 2017-09-14 10:56:52.792 7fab3bc417c0 INFO logging contrib/epee/src/mlog.cpp:156 New log categories: *:WARNING,net:FATAL,net.p2p:FATAL,net.cn:FATAL,global:INFO,verify:FATAL,stacktrace:INFO,logging:INFO,msgwriter:INFO 2017-09-14 10:56:52.991 7fab3bc417c0 INFO logging contrib/epee/src/mlog.cpp:156 New log categories: *:WARNING,net:FATAL,net.p2p:FATAL,net.cn:FATAL,global:INFO,verify:FATAL,stacktrace:INFO,logging:INFO,msgwriter:INFO 2017-09-14 10:56:53.037 7fab1bfff700 ERROR net.http contrib/epee/include/storages/portable_storage.h:161 portable_storage: wrong binary format - signature mismatch 2017-09-14 10:56:53.037 7fab1bfff700 ERROR wallet.wallet2 src/wallet/wallet2.cpp:2128 !r. THROW EXCEPTION: error::invalid_password 2017-09-14 10:56:53.037 7fab1bfff700 WARN net.http src/wallet/wallet_errors.h:707 /home/vagrant/slave/monero-core-ubuntu-amd64/build/monero/src/wallet/wallet2.cpp:2128:N5tools5error16invalid_passwordE: invalid password 2017-09-14 10:56:53.038 7fab1bfff700 ERROR WalletAPI src/wallet/api/wallet.cpp:504 Error opening wallet: invalid password 2017-09-14 10:56:53.077 7fab1bfff700 ERROR WalletAPI src/wallet/api/wallet.cpp:553 Status_Critical - not storing wallet 2017-09-14 10:57:04.550 7fab1b7fe700 WARN net.dns src/common/dns_utils.cpp:487 WARNING: no two valid MoneroPulse DNS checkpoint records were received

1

I am told the program doesn't exist even though the ls command shows it very clearly.

Need more info here. Sounds like monerod is just not in your $PATH perhaps? If so, you need to use the full path to the executable.

monero-wallet-gui. log says...

I see invalid password in the log, have you checked for sure that the password is correct? (remove all special characters / symbols to test). Are you even using a username / password?

Are you sure that monerod is configured to accept incoming RPC on IP 127.0.0.1 and port 18081? (the default)

  • Thank you. The invalid password was a mistype and was fixed on the next try. The settings page of the GUI definatly says localhost and 1881 for the port. As nearly as I can tell from the logs, I am attempting to access 127.0.0.1. I have two Ubuntu 14.04 computers, and the same problem occurs on both. But I am also running a machine on Archlinux/Mate and the GUI and block chain work great on it, so the problem seems to be related to Ubuntu. – user592440 Sep 22 '17 at 14:46
  • @user592440 If the password is fixed, please replace log message above with the current one. If the same setup works on another Linux machine, then it might be a firewall (like ufw) blocking the port? I recommended the simple password because I once configured a password using # char and didn't realize it was being interpreted as a comment in the config file ;-) – Jonathan Cross Sep 23 '17 at 12:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.