I have been using a wallet generated using monero-wallet-cli on Ubuntu. I have not yet received funds on this address, but have been mining in a pool using this address. I had a harddisk problem so I used a new harddisk to install Ubuntu on, and restored my wallet from seed. I noticed the wallet-id that I used for mining on the previous harddisk, is different from the wallet-id that is generated from the 25 word seed. I have tried twice, both times the same (new) id was generated. As I have not received any payment, I can not check wheter the account balance is the same, but I'd like to receive the mining payments, once my threshold is reached.

Is this normal behaviour? Are the 2 address id's pointing to the same info? A Google search did not get me an answer to this question.

2 Answers 2


A same seed will restore the same wallet. Checking the address is a good way to check that you got your seed right. For example, the seed

tanks ticket muffin eclipse lectures degrees gymnast technical deodorant hefty lunar casket zapped bovine skater bypass frying acquire inkling ammo army myriad soggy tepid hefty

will always result in the address


However, that's a standard address. If you use integrated address (which is just your address + some random data packed in), then it will be slightly different for each different payment ID packed in:

  1. 4Kst5UxowGMdXtMdmgKF4pHg1qPthzmtBXiBMKLT3rPT4L7gCAKMZ1yD9nA3JVCVRpWn9X3aZeqKkfX81bemg2V2hVfa2bxWtuzMXeekK9 (payment ID = 1961b07fc64d25b5)
  2. 4Kst5UxowGMdXtMdmgKF4pHg1qPthzmtBXiBMKLT3rPT4L7gCAKMZ1yD9nA3JVCVRpWn9X3aZeqKkfX81bemg2V2hbkcazxrXezR8kXAqL (payment ID = ba01b042e8b04bd5)

and so on.

Even if the letters look different, all these addresses are encoding the same thing. Your public spend and public view key + optional payment ID.

Funds sent to all 3 addresses will go to the same wallet, but the last 2 will come in with a "message" (payment ID).

You can play around to see how it works here.

  • OK, than I guess I wrote down the seed words incorrectly. A mistake to learn from...
    – Tjeerd
    Commented Sep 6, 2017 at 12:57
  • That's rather strange, since if you make a mistake there's a checksum to alert you. Maybe you mixed up wallets? If you messed up just 1 word it's not hard to restore by guessing.
    – JollyMort
    Commented Sep 6, 2017 at 14:42
  • Also for me. I generated one year ago a wallet and I made 2 paper backups of the seed. I funded primary address and now I cannot restore my wallet from seed because that seed is generating another primary address totally different from the original I funded. I'm sure that I double checked each word of the seed. I can't understand why now the same seed generates a different wallet. I haven't more than 1 wallet. I can't confuse with other wallets because I have generated only this. I tried to change language of the seed with no results. I tried to restore using precedent release of monero-wallet
    – bissiol
    Commented Feb 19, 2021 at 17:50

In case anyone else is looking - As far as I can tell, a wallet recovery using a 25 word seed should always generate a new wallet with the same address and seed. However, if you make any change during the recovery process, it will result in a different wallet. In my case, I was recovering a wallet using the Monero CLI, and when it prompted me for the "passphrase offset", I mistakenly entered what I thought it was. It turns, I had never actually set this for my original wallet. When I left the passphrase empty (just pressed enter), then my wallet was recovered successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.