1

I've tried using a public node as well as a local node, but the wallet never seems to connect.

If I run the GUI via the terminal (./monero-wallet-gui --daemon-host 127.0.0.1:18080), I get some log output that matches what I'd expect:

2017-08-21 13:00:17.307 ERROR net.http contrib/epee/include/net/http_client.h:387 HTTP_CLIENT: Failed to SEND 2017-08-21 13:00:27.310 ERROR net.http contrib/epee/include/net/http_client.h:441 Unexpected recv fail

This repeats several times over.

What am I doing wrong?

  • try use ./monero-wallet-gui --daemon-address 127.0.0.1:18080 instead – JollyMort Aug 21 '17 at 18:47
1

There are 2 different start-up options:

--daemon-address arg                Use daemon instance at <host>:<port>
--daemon-host arg                   Use daemon instance at host <arg> instead

You're using the one for hostname so it's expecting localhost:18080 or similar.

To make it recognize the IP, use the --daemon-address option, like:

./monero-wallet-gui --daemon-address 127.0.0.1:18080

1

You're trying to connect the GUI to the P2P port, but the GUI expects to talk to the RPC port. Try this instead:

./monero-wallet-gui --daemon-address 127.0.0.1:18081

Alternatively, just run:

./monero-wallet-gui

since those are the defaults.

This assumes you did not configure monerod to use 18080 as RPC port, and another custom P2P port. While it is possible, it is pretty unlikely.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.