4

I have a 24/7 full-node of 10.3.1 on win7 x64

It runs with --restricted-rpc --block-sync-size 10 --rpc-bind-ip xx.xx.xx.xx --confirm-external-bind --data-dir C:\Users\user\Documents\XMRdb --add-priority-node xx.xx.xx.xx:18080 --limit-rate-up 1000

It works well at start, but the RAM consumption always gets bigger and bigger after a few hours. In the end, it eats up all my 16 GB RAM.

I tried to change block-sync-size back to 200, limit-rate-up to 50. But no help.

The status: Height: 1351515/1351515 (100.0%) on mainnet, not mining, net hash 119.56 MH/s, v 5, up to date, 8(out)+35(in) connections, uptime 1d 22h 25m 24s

How can I limit the RAM consumption?

3

It eats up all the RAM because it uses a very large memory mapped database (up to about 20 GB for now), and nothing else seems to need the RAM. If you really want to limit it, you could check ulimit (a bash internal command), which allows you to limit memory consumption:

$ ulimit -a
[...]
virtual memory (kbytes, -v) unlimited

eg, to limit usage to a bit less than 5 GB: ulimit -v 5000000

Note that if other programs need the RAM, they'll just take it, LMDB won't hold on to it (within reason). Unused RAM is not helping anyone, after al.

  • Thanks for your answer. But the strange thing is that another node I build at different place only consumes about 1 GB even after 10 days. The status: Height: 1351758/1351758 (100.0%) on mainnet, not mining, net hash 114.72 MH/s, v5, up to date, 0(out)+6(in) connections, uptime 10d 4h 7m 31s – Lafudoci Jul 11 '17 at 9:12
  • I have been running monerod with just the default options and uptime of 22 days and it just eats 131MB. – Gundamlancer Jul 11 '17 at 9:19
1

It looks like docker stats is incorrectly reporting memory utilization. Check with htop

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.