2

I have installed the Monero GUI and it was giving some errors so I went back to the cli. When I run ./monerod everything seems to work fine but when I do status it gives me -
Height: 1346603/1346603 (100.0%) on mainnet, not mining, net hash 99.90 MH/s, v5, up to date, 0(out)+0(in) connections, uptime 0d 0h 11m 57s
Why is it not connecting to peers? When I do start_mining it gives the error Error: Mining did not start -- BUSY. I looked at this to try and solve my issue but it still did not connect. I am using Ubuntu 17. Thank you for any help.

1

We can't tell without more information.

If you'd left monerod not running for a long time, it's plausible that it'll try to contact nodes which were running, but are not (either they're now down, or they were on dynamic IPs which changed since, etc).

It is also possible that peers banned your node. This would normally only happen if your node is on a bad fork and sends incorrect data to those other nodes. Check you are using monerod 0.10.3.1.

Another possibility is that your network connectivity is down.

To check what the network layer is doing: set_log 1.

To try and reset the set of known peers: exit monerod, rm ~/.bitmonero/p2pstate.bin, start monerod again

  • I am using monero 0.10.3.1 and connected to the internet while I am running monerod, I also reset the known peers with no avail. I have been getting a warning "no two valid MoneroPulse DNS checkpoint records were received" But I read somewhere else that it wasn't an issue. When I set log_level one I get many errors and warnings, the most prevalent are "-4, LEVIN_ERROR_CONNECTION_TIMEDOUT". I restarted monerod just to see if I would get the same errors and I had no output besides the dns warning. – Peyto Jul 5 '17 at 18:32
  • The DNS warnings are indeed ignorable at this pont. Timeouts are also ignorable, they're typically about trying to reach nonexistent nodes. – user36303 Jul 5 '17 at 18:48
  • Then what am I to do? None of the options above worked. – Peyto Jul 5 '17 at 20:41
  • What is the top hash shown when you run the diff command ? – user36303 Jul 6 '17 at 9:55
  • TH: f67cfa6b68c204d2f0ad7af2bbcfd5b233fba400a24bb7152ce11e5cc63f2ab2 – Peyto Jul 7 '17 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.