I want to pool mine Aeon with a CPU on macOS. How do install a CryptoNote-Lite miner? Preferably using open-source where I can compile myself (procedure needed).

2 Answers 2


I know it's been a while since you asked this, but in case anyone else is wondering, you can easily install xmrig on MacOS by following the build instructions on Github.

First you need to install Xcode from the App Store, and then you have to install Homebrew.

Once you have those dependencies, you need to run the commands given on the xmrig OS X Build instructions page (from a Terminal window):

brew install cmake libuv
git clone https://github.com/xmrig/xmrig.git
cd xmrig
mkdir build
cd build
cmake ..

Once the compile process finishes successfully, there will be a binary executable in the build directory named xmrig. You can verify that it is there by running this command in the build directory:

ls -lah | grep xmrig

Run xmrig in OS X the same way you would in Linux. From the build directory, run the following command (I've included my preferred pool... feel free to replace it with whatever you use):

./xmrig -a cryptonight-lite -o "mine.aeon-pool.com:3333" - u YOUR_WALLET_ADDRESS -p x

You can optionally specify a donation level. By default, xmrig donates 5% of your mining time to the developer, but you can set it as low as 1%, depending on your generosity preferences.

Note: If you have a good CPU (hashrates over 300 H/s), you might want to mine on port 5555 instead of 3333, since it will start you at a higher difficulty (better earnings). Check your pool's "Getting Started" page for more details about what port numbers and difficulties are available.

  • could you please write the command that has to be used as xmrig.exe would be for windows what is for mac ... Oct 1, 2017 at 14:30
  • @TaraqKamdar I added that for you. Sorry. I've been a Linux sysadmin for 10 years, so I sometimes forget that other people don't know how to run programs from a Unix terminal.
    – blendenzo
    Oct 2, 2017 at 16:13
  • Thanks, but I cannot get this to work. Initial error I had was Could NOT find UV (missing: UV_LIBRARY UV_INCLUDE_DIR), which was solved by doing cmake .. -DUV_INCLUDE_DIR=… -DUV_LIBRARY=… per GitHub issue 72. However, then needed to add -DWITH_HTTPD=OFF. And after that, I am stuck with another error CMake Error: The following variables are used in this project, but they are set to NOTFOUND. Please set them or make sure they are set and tested correctly in the CMake files: MHD_LIBRARY (ADVANCED) which I have no idea how to resolve.
    – dpzz
    Oct 11, 2017 at 21:49
  • @dpzz You should not be getting errors about cmake being unable to find UV if you properly installed UV using brew install libuv. Also, what version of OS X are you using? My successful compile was in Sierra. I haven't updated to High Sierra.
    – blendenzo
    Oct 11, 2017 at 22:18
  • @blendenzo I installed UV like you quoted (together with cmake as in the instructions above). Those UV errors were fixed with the 2 -D flags as I commented. However, the MHD_LIBRARY error I could not solve. I am also on Sierra (10.12.6). Strange …
    – dpzz
    Oct 11, 2017 at 23:09

Based on Jaste's comment on Reddit, I tried compiling AEON-STAK-CPU on macOS Sierra (10.12.6). I encountered a few issues, this is how it worked for me:


  1. Make sure Apple's Xcode and Homebrew are installed.
  2. Download the source code from shyba's AEON-STAK-CPU GitHub repository. Click the green button Clone or download and then Download ZIP. Unzip it.
  3. Install a few dependencies using Homebrew (I already had the last 2 apparently):

    • brew install libmicrohttpd
    • brew install cmake
    • brew install openssl

  5. make

This produced the binary aeon-stak-cpu in the bin subdirectory.


I would have prefered to not disable those 2 options during the cmake step. Even though I had installed libmicrohttpd using Homebrew, I couldn't find a way to get it to work yet. If anyone knows how to specify it, please say so.


Using the miner requires you to configure the config.txt file first. Besides, the typical pool and your wallet information, which every mining pool's "Getting Started" page normally shows, you'll also have to update the cpu_threads_conf section in it. Fortunately, it will be shown when you first start it, so just copy and paste it.


In addition to that, I also get the following error:


I resolved it by following the advice in GitHub issue #8 and changing the following part in the config.txt file: "use_slow_memory" : "always", instead of "use_slow_memory" : "never",.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.